Closed Bug 1320580 Opened 3 years ago Closed 3 years ago

HTML custom border using SVG partially broken for "round" repeat

Categories

(Core :: General, defect)

50 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1315353

People

(Reporter: xenos, Unassigned)

Details

Attachments

(4 files)

Attached image Firefox.PNG
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20161104212021

Steps to reproduce:

I've changed nothing on my website https://dracca.com where I use custom borders

.homepage {
  border-color: hsla(0, 0%, 0%, 0);
  border-image: url("../img/arriere-plan-parchemin.svg") 60 40 85 50 stretch round;
  border-radius: 0.5em;
  border-style: solid;
  border-width: 60px 40px 85px 50px;
}


Actual results:

It rendered well in Firefox 47 and it still does render well in Opera (41) but it no longer renders well in Firefox 50. Part of the SVG (one group in fact) is properly rendered, the rest is all blurry. It only affects the left and right borders, which are using "round", while the top and bottom renders well (they use "stretch"). Changing "round" to "stretch" makes the left/right borders render well too. 

So it's a regression in how "round" is rendered/calculated.


Expected results:

Firefox 50 should still display as Firefox 47 or Opera 41.
Added the screen of how it's rendered in Opera (and it was rendered the same way in Firefox 47). I don't know how it was rendered in FF48 nor FF49.
The website is not available, can you just attach a reduced testcase (the svg)?
Flags: needinfo?(xenos)
Attached file Autonomous showcase
Showcase added.

But you're worrying me a bit: it's available for me, and looks available according to WebPageTest (which also shows the same bug in the rendered screenshot https://www.webpagetest.org/result/161127_K2_VCY/ so it's probably not any of my plugins but a real FF bug)
Fixed in 51+.
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Flags: needinfo?(xenos)
Resolution: --- → DUPLICATE
Duplicate of bug: 1315353
You need to log in before you can comment on or make changes to this bug.