[geckoview] Make GeckoView.loadUri work in geckoview.{xul,js}

RESOLVED DUPLICATE of bug 1322592

Status

()

Firefox for Android
GeckoView
RESOLVED DUPLICATE of bug 1322592
a year ago
a year ago

People

(Reporter: nalexander, Assigned: esawin)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
After Bug 1285572, geckoview.js must set up an nsIBrowserDOMWindow (see http://searchfox.org/mozilla-central/source/dom/interfaces/base/nsIBrowserDOMWindow.idl#32) in order for loadUri to function.  This interface allows a pleasant API for loading content URIs into a <browser> embedded in a given chrome <window>.
(Reporter)

Comment 1

a year ago
Modulo flags that make no sense in GeckoView (switching tabs, new windows, etc), I have this mostly in place.  I'll post patches when I clean them up and add some basic tests.
(Assignee)

Updated

a year ago
Assignee: nobody → esawin
(Assignee)

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1322592
You need to log in before you can comment on or make changes to this bug.