Closed Bug 1320732 Opened 4 years ago Closed 26 days ago

Checkbox and radio input fields should not force an !important border

Categories

(Firefox for Android Graveyard :: Theme and Visual Design, defect, P5)

defect

Tracking

(firefox53 fixed, firefox55 disabled)

RESOLVED INCOMPLETE
Firefox 53
Tracking Status
firefox53 --- fixed
firefox55 --- disabled

People

(Reporter: mconley, Assigned: mconley)

References

Details

(Whiteboard: [webcompat])

Attachments

(2 files)

In bug 418833, we made checkbox and radio input fields more style-able. As part of that, we also got rid of some !important user agent styles from those fields.

There are some leftover styles in Fennec's content.css that prevent a site author from overriding the border on those fields:

http://searchfox.org/mozilla-central/rev/957458d8fa2328c2a760dbb30e7f1f1efa55b4d0/mobile/android/themes/core/content.css#188

That !important was probably there because there was an !important in Gecko's forms.css which it needed to override. Since forms.css had its !important removed, this !important can probably go too.
Assignee: nobody → mconley
Comment on attachment 8814992 [details]
Bug 1320732 - Make sure borders for checkbox and radio input fields can be styled on Fennec.

https://reviewboard.mozilla.org/r/96022/#review96124
Attachment #8814992 - Flags: review?(snorp) → review+
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/36be06539887
Make sure borders for checkbox and radio input fields can be styled on Fennec. r=snorp
Whiteboard: [webcompat]
https://hg.mozilla.org/mozilla-central/rev/36be06539887
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 53
Hey Mike, this broke Donald Trump's media survey in Fennec:

https://github.com/webcompat/web-bugs/issues/4726#issuecomment-280560444

Do you think we should attempt reaching out to Trump over in webcompat land (lol?), or open a Bugzilla bug?
Flags: needinfo?(mconley)
(In reply to Mike Taylor [:miketaylr] from comment #5)
> 
> Do you think we should attempt reaching out to Trump over in webcompat land
> (lol?), or open a Bugzilla bug?

Hrm. Re-reading bug 418833, I think getting rid of the stroke on the radio buttons was intentional. See bug 418833 comment 123.

Am I correct when I interpret that request as "we should make the stroke hide-able, but ONLY if -moz-appearance: none is set"?
Flags: needinfo?(mconley) → needinfo?(miket)
That's how I interpret https://bugzilla.mozilla.org/show_bug.cgi?id=418833#c32, so.... it seems like there's a missing piece to the puzzle. I'll try to reduce things over in the linked webcompat bug and get a better understanding (because right now I *don't* see -moz-appearance: none set on those inputs)
Flags: needinfo?(miket)
(In reply to Mike Taylor [:miketaylr] from comment #7)
> That's how I interpret
> https://bugzilla.mozilla.org/show_bug.cgi?id=418833#c32, so.... it seems
> like there's a missing piece to the puzzle.

The missing piece of the puzzle might be, "I goofed". I suspect the change I made in this bug applies even if -moz-appearance is not set to none.

I don't currently have a debug-my-Fennec rig set up, and I have to run to a meeting. I'll confirm this shortly, and then we should probably get a bug filed.
Flags: needinfo?(mconley)
Attached file no-border.html
Ah yeah, seems like that's the bug, as this TC shows (on Fennec, does not repro on Desktop). I'll file a bug and block this one.
Depends on: 1340661
Flags: needinfo?(mconley)
This has been backed out of mozilla-central (Nightly 55) via bug 1345956.

https://hg.mozilla.org/mozilla-central/rev/7f9f8d164fce
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Request for aurora and beta approval for the backout has been made here: https://bugzilla.mozilla.org/show_bug.cgi?id=1345956#c7
Re-triaging per https://bugzilla.mozilla.org/show_bug.cgi?id=1473195

Needinfo :susheel if you think this bug should be re-triaged.
Priority: -- → P5

Migrating Webcompat whiteboard priorities to project flags. See bug 1547409.

Webcompat Priority: --- → ?

See bug 1547409. Migrating whiteboard priority tags to program flags.

Webcompat Priority: ? → ---
We have completed our launch of our new Firefox on Android. The development of the new versions use GitHub for issue tracking. If the bug report still reproduces in a current version of [Firefox on Android nightly](https://play.google.com/store/apps/details?id=org.mozilla.fenix) an issue can be reported at the [Fenix GitHub project](https://github.com/mozilla-mobile/fenix/). If you want to discuss your report please use [Mozilla's chat](https://wiki.mozilla.org/Matrix#Connect_to_Matrix) server https://chat.mozilla.org and join the [#fenix](https://chat.mozilla.org/#/room/#fenix:mozilla.org) channel.
Status: REOPENED → RESOLVED
Closed: 4 years ago26 days ago
Resolution: --- → INCOMPLETE
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.