[meta] Slow startup in Debug builds

NEW
Unassigned

Status

()

Core
General
a year ago
11 months ago

People

(Reporter: jesup, Unassigned, NeedInfo)

Tracking

({meta})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ele:1b])

(Reporter)

Description

a year ago
Debug non-optimized builds are impressively slow to start, perhaps 30x slower that an opt/nodebug build.  Some of this is expected of course (extra checks, and little or no optimization both slow things down considerably), but the slowness seems more extreme than you see after startup is complete.

There may or may not be anything actionable here, but worth keeping an eye on
(Reporter)

Comment 1

a year ago
A quick look at jprofs of non-e10s startup with opt non-debug vs non-opt debug builds shows roughly similar performance, so it may just be "everything is slower" (code perf, and added tests) but no hot-spot
Hello, I'm asking your help with an experiment with making decisions on bugs. You've been needinfo'ed on this bug. I'd like you to take one action to help this bug make progress toward a decision. The things you can do include:

* If you know or have a good guess of which product and component this bug belongs to, change the product and component of the bug
* If you know of the right person to ask about this bug, redirect the needinfo to them
* If you cannot reproduce the bug, close it

All we need you to do is one thing that will help us make a decision on the bug or resolve it.

Thank you for your help with this. If you have questions, please contact emma@mozilla.com.
Flags: needinfo?(anthony.s.hughes)
Whiteboard: [ele:1b]
(In reply to Emma Humphries ☕️ (she/her) [:emceeaich] (UTC-8) +needinfo me from comment #2)
> If you know or have a good guess of which product and component this bug
> belongs to, change the product and component of the bug

I suspect this belongs in the component related to the code where the slowdown is occurring but I don't have enough details to make that determination. Perhaps this could move to Core::XPCom if nothing else.

:jesup, is this issue still reproducible? Do you know where it belongs?
Flags: needinfo?(anthony.s.hughes)
(In reply to Anthony Hughes (:ashughes) [GFX][QA][Mentor] from comment #3)
> :jesup, is this issue still reproducible? Do you know where it belongs?

Sorry, Missed setting the needinfo flag.
Flags: needinfo?(rjesup)
You need to log in before you can comment on or make changes to this bug.