devtoolschallenger.com is down

RESOLVED FIXED

Status

Infrastructure & Operations
WebOps: SSL and Domain Names
RESOLVED FIXED
a year ago
11 months ago

People

(Reporter: clarkbw, Assigned: ericz)

Tracking

Details

(Whiteboard: [kanban:https://webops.kanbanize.com/ctrl_board/2/3793])

In bug 1299258 we transferred over the domain devtoolschallenger.com and when I checked it days later it worked but now I'm realizing it could have still been cached.

It seems the domain is no longer working.  Can someone investigate?

Updated

a year ago
Whiteboard: [kanban:https://webops.kanbanize.com/ctrl_board/2/3793]

Updated

a year ago
Assignee: server-ops-webops → eziegenhorn
(Assignee)

Comment 1

a year ago
Yes the domain no longer resolves.  The nameservers for it are ns[1-3].digitalocean.com.  Perhaps the relevant digitalocean account is no longer working?  I have no ability to investigate there.
It used to point to a github page, I'll have to grab the old settings.
It used to point here: https://mozilla.github.io/deepdev
(Assignee)

Comment 4

a year ago
That github page just redirects to the nonworking devtoolschallenger.com for me.  And to be clear, IT doesn't control the DNS entries for that domain, a digitalocean account does.  From 1299258, I'm guessing that could be Jen's as well but don't know.  If she can't help, we can take control of the domain and host DNS on our infrastructure to be able to point the website to where you want.
(In reply to Eric Ziegenhorn :ericz from comment #4)
> If she can't help, we can take control of the
> domain and host DNS on our infrastructure to be able to point the website to
> where you want.

I think that's the right thing to do here.  She no longer works for Mozilla and probably forgot about the digitalocean part.
(Assignee)

Comment 6

a year ago
Ok, I'll switch DNS nameservers to Mozilla.  At that point, we can make devtoolschallenger.com point somewhere else, but we can't make top level CNAMEs so it can't be an alias for that github page.  We could make e.g. www.devtoolschallenger.com redirect to the github page though if something like that would work.
If that will work, lets go with that.
(Assignee)

Comment 8

a year ago
That will work if you can get the github page to actually be a content page instead of redirecting as it does now:

$ curl -I https://mozilla.github.io/deepdev
HTTP/1.1 301 Moved Permanently
Location: http://devtoolschallenger.com
<snip>

It is only a redirect now, as if the content lived elsewhere (perhaps on that Digital Ocean account that no longer works).  Do you have the content?
I don't have admin privs for https://github.com/mozilla/deepdev so I'll need to get that kind of access first to be able to change anything.

But as far as I understand this is a CNAME to a github page, https://help.github.com/articles/setting-up-a-www-subdomain/ , if we can't do that I'm not sure how else we should get this setup again.
(Assignee)

Comment 10

a year ago
Right, the CNAME is what we want once we have a page of content to point to.  Currently the content seems to be lost -- it isn't on that github page.
I suspect that https://mozilla.github.io/deepdev is only redirecting because the server detects that the requested location is not http://devtoolschallenger.com . As soon as the ALIAS / ANAME record of devtoolschallenger.com points to mozilla.github.io, devtoolschallenger.com should automatically show the correct content.

At the moment, the ALIAS / ANAME record of devtoolschallenger.com does not point to mozilla.github.io:

> $ nslookup devtoolschallenger.com
> Server:		8.8.8.8
> Address:	8.8.8.8#53
> 
> ** server can't find devtoolschallenger.com: NXDOMAIN

> $ dig devtoolschallenger.com +nostats +nocomments +nocmd
> 
> ; <<>> DiG 9.8.3-P1 <<>> devtoolschallenger.com +nostats +nocomments +nocmd
> ;; global options: +cmd
> ;devtoolschallenger.com.		IN	A

Instructions are on https://help.github.com/articles/setting-up-an-apex-domain/
Flags: needinfo?(eziegenhorn)
(Assignee)

Comment 12

11 months ago
It seems to 404 even if I give it the devtoolschallenger.com hostname, see below, but I'll still go ahead with the DNS changes as it's currently broken so this is no worse and probably closer to what we want.  We should be able to figure out.  Currently I'm seeing errors transferring the domain but I'll keep working on that.

$ curl -vH'Host: devtoolschallenger.com' https://mozilla.github.io/deepdev/
*   Trying 151.101.44.133...
* Connected to mozilla.github.io (151.101.44.133) port 443 (#0)
* TLS 1.2 connection using TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256
* Server certificate: www.github.com
* Server certificate: DigiCert SHA2 High Assurance Server CA
* Server certificate: DigiCert High Assurance EV Root CA
> GET /deepdev/ HTTP/1.1
> Host: devtoolschallenger.com
> User-Agent: curl/7.49.1
> Accept: */*
>
< HTTP/1.1 404 Not Found
< Server: GitHub.com
< Content-Type: text/html; charset=utf-8
< ETag: "582a2740-247c"
< Access-Control-Allow-Origin: *
< Content-Security-Policy: default-src 'none'; style-src 'unsafe-inline'; img-src data:; connect-src 'self'
< X-GitHub-Request-Id: 17EB281E:51B9:1719A07:5853095E
< Content-Length: 9340
< Accept-Ranges: bytes
< Date: Thu, 15 Dec 2016 21:21:35 GMT
< Via: 1.1 varnish
< Age: 0
< Connection: keep-alive
< X-Served-By: cache-ord1745-ORD
< X-Cache: MISS
< X-Cache-Hits: 0
< X-Timer: S1481836894.479316,VS0,VE936
< Vary: Accept-Encoding
< X-Fastly-Request-ID: 332be97c6d89e064a8b4cbc587fc2178c7b1fb7e
<
Flags: needinfo?(eziegenhorn)
(In reply to Eric Ziegenhorn :ericz from comment #12)
> $ curl -vH'Host: devtoolschallenger.com' https://mozilla.github.io/deepdev/

$ curl -vH'Host: devtoolschallenger.com' https://mozilla.github.io/

works.
(Reporter)

Comment 14

11 months ago
Did the DNS change go through?  I'm still seeing the same response as comment 11

Comment 15

11 months ago
(In reply to Bryan Clark (DevTools PM) [:clarkbw] from comment #14)
> Did the DNS change go through?  I'm still seeing the same response as
> comment 11

I'm seeing the same thing. It's still down :(
(Assignee)

Comment 16

11 months ago
We have taken control of DNS back yes.  2 A records have been created as per github and http://devtoolschallenger.com/ now works for me.
I can confirm it's back now. Thanks!
(Assignee)

Updated

11 months ago
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.