implement silent download in download manager

RESOLVED WORKSFORME

Status

()

--
enhancement
RESOLVED WORKSFORME
17 years ago
9 months ago

People

(Reporter: moz, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
download manager should support silent download, or better download priorities
(Reporter)

Updated

17 years ago
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

17 years ago
Summary: [REF] implement silent download in download manager → [RFE] implement silent download in download manager
What is "silent download"?
(Reporter)

Comment 2

17 years ago
see the url :)

>SilentDownload is a background transfer method that allows files to be
downloaded >to the users machine without interfering with their network performance.

i searched in the mozilla tree, but didn't found any code, maybe its not
finished or not maintained anymore.
As far as I know it was never implemented.

Comment 4

17 years ago
*** Bug 141050 has been marked as a duplicate of this bug. ***

Comment 5

17 years ago
If im right silent download automaticly stops downloads when pages are
downloading and carrys on in the background when viewing pages?
This would make Mozilla and supsequently Netscape very popular with people on
modems reviewers would go mad for this.

Updated

16 years ago
Blocks: 157731

Comment 6

16 years ago
In combination with bug 131871 this would make an excellent system for modem
users to download large files over several sessions without disrupting browsing
sessions.
QA Contact: sairuh → petersen
Summary: [RFE] implement silent download in download manager → implement silent download in download manager

Comment 7

15 years ago
I think this bug needs more atention.

Comment 8

15 years ago
I agree with alex, reviewers WOULD go mad for this, this really does need more
attention.
Product: Browser → Seamonkey
*** Bug 338883 has been marked as a duplicate of this bug. ***
Assignee: bross2 → download-manager
QA Contact: chrispetersen

Updated

9 years ago
Assignee: download → nobody
Component: Download & File Handling → Download Manager
Product: SeaMonkey → Toolkit
QA Contact: download.manager

Comment 10

9 months ago
Since all legacy addons are disabled now, I think we need to go through this again.
Flags: needinfo?(paolo.mozmail)

Comment 11

9 months ago
This functionality has already been implemented as network throttling.
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Flags: needinfo?(paolo.mozmail)
Resolution: --- → WORKSFORME

Comment 12

9 months ago
(In reply to :Paolo Amadini from comment #11)
> This functionality has already been implemented as network throttling.

Could you explain more a bit? As I found no mean to get rid of confirmation dialog before download.

Comment 13

9 months ago
Per comment 2, this bug was about a different feature than what the title seemed to suggest.

I think removing the confirmation dialog before downloads is a good idea. There is already a design and there is bug 1306339 on file for it, but it is a lot of work and we don't have people available to work on it now. It will happen at some point, but probably not soon.
You need to log in before you can comment on or make changes to this bug.