Dead keys working incorrectly in Mac OS X since FF ver. 50

RESOLVED DUPLICATE of bug 1317906

Status

()

Core
Widget: Cocoa
P2
normal
RESOLVED DUPLICATE of bug 1317906
a year ago
7 months ago

People

(Reporter: sor.rge, Assigned: masayuki)

Tracking

({inputmethod, regression})

50 Branch
x86_64
Mac OS X
inputmethod, regression
Points:
---

Firefox Tracking Flags

(firefox50 wontfix, firefox51 fixed, firefox52 fixed, firefox53 fixed)

Details

(Whiteboard: tpi:+)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20161123182536

Steps to reproduce:

In Mac OS X, when you type the first key in a dead key sequence, followed by a key that is not in any dead key sequence, you get two characters: the first dead key character and the second one that was pressed. Since Firefox v. 50 update, the second key press is ignored. Example: in the Norwegian keyboard layout, there is a dead key sequence [¨][e], which results in "ë". But if you type [¨][r], normally it will result in "¨r". In the new Firefox, it will result in "¨". It is very difficult to keep track of all "eaten" characters when typing text, which results in massive amount of typos.

Steps to reproduce:
Use Norwegian keyboard, press [¨] and then [r] in Firefox in any text input field (web page, address line, search etc.)


Actual results:

The text "¨" is entered.


Expected results:

The text "¨r" should have been entered.
Component: Untriaged → Widget: Cocoa
Keywords: inputmethod
Product: Firefox → Core
I guess that this was already fixed in 51 Beta 3. Could you check it?
https://www.mozilla.org/en-US/firefox/channel/desktop/
Flags: needinfo?(sor.rge)
Confirmed this bug on Release Fx50.0.120161123182536 with macOS 10.12  
It works as expected on 51.0b4, 20161128075558 and Nightly 53.0a1, 20161129030222

note: for those using English (American) keyboards and changing input source to Norwegian,  "¨" is the "]" key.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(sor.rge)
OS: Unspecified → Mac OS X
Priority: -- → P2
Hardware: Unspecified → x86_64
Whiteboard: tpi:+
Thank you very much. I guess that this is dup of bug 1317906, I'll check that in a couple of hours. (If this is a dup of bug 1317906, it'll be fixed in 50.1.0 to be released mid Dec.)
Assignee: nobody → masayuki
Status: NEW → ASSIGNED
status-firefox50: --- → affected
status-firefox51: --- → fixed
status-firefox52: --- → fixed
status-firefox53: --- → fixed
Keywords: regression
Okay, I confirmed that this is exactly a dup of bug 1317906.
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1317906
status-firefox50: affected → wontfix
You need to log in before you can comment on or make changes to this bug.