URL bar should not lose focus until page starts loading

RESOLVED DUPLICATE of bug 90919

Status

--
minor
RESOLVED DUPLICATE of bug 90919
17 years ago
11 years ago

People

(Reporter: mpt, Assigned: hewitt)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Build: 2002031808, Mac OS 9.2

To reproduce:
1.  In the address field, type http://mozilla.com
2.  Press Enter
3.  Realize your mistake, and press Backspace three times to delete the `com'

What should happen:
*   The `com' is deleted.

What actually happens:
*   Nothing.

Comment 1

17 years ago
Seems like this would be really easy to fix...
Keywords: 4xp
(Reporter)

Comment 2

17 years ago
Arg. So that this bug doesn't get marked as a duplicate of bug 54321, a 
clarification:

3.  Realize your mistake, and press Backspace three times to delete the `com',
    *before* anything new appears in the content area.

That is, the browser should wait until stuff starts loading in the content area 
before switching focus to it.

Comment 3

17 years ago
We also shouldn't switch focus to the content area if the server returns an
error such as 404, or if we're displaying a placeholder page such as "cannot
find server".

When fixing this, make sure that the way you call focus() doesn't cause the
window to jump in front of other windows as soon as the page begins to load. 
(Is there a bug about the dual meaning of focus()?)
Severity: trivial → minor
OS: Mac System 9.x → All
Hardware: Macintosh → All

Updated

17 years ago
Blocks: 55416

Comment 4

17 years ago

*** This bug has been marked as a duplicate of 90919 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.