Closed Bug 1321012 Opened 3 years ago Closed 1 year ago

SVG: browser hang with animateMotion

Categories

(Core :: SVG, defect, P3, critical)

50 Branch
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox-esr52 --- wontfix
firefox55 --- wontfix
firefox56 --- wontfix
firefox57 --- affected
firefox58 --- affected
firefox65 --- unaffected
firefox66 --- unaffected
firefox67 --- unaffected

People

(Reporter: tsmith, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: hang, perf, testcase)

Attachments

(1 file)

Attached file test_case.html
Loading this test case will cause the browser to hang. It seems to be due to the path attribute in the animateMotion element.
Likely similar to https://bugzilla.mozilla.org/show_bug.cgi?id=1322537 (though the testcase here doesn't rely on a absurdly huge value).
See Also: → 1322537
Keywords: perf
Priority: -- → P3
Confirmed that trunk is still affected.
Has Regression Range: --- → no
Severity: normal → critical
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.