Closed Bug 1321028 Opened 3 years ago Closed 11 months ago

show that update is downloaded and installed and restart is needed

Categories

(Toolkit :: Application Update, defect)

63 Branch
x86_64
Windows 10
defect
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: qdinar, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20161123182536

Steps to reproduce:

i do not turn firefox off, i only put laptop into sleep


Actual results:

i have to manually check firefox updates, and i check them rarely in menu - help - about, or i see them in news in sites, and maybe that i know about it several days after it is downloaded


Expected results:

i want to see some notification when update is installed and i should restart firefox
Component: Untriaged → Application Update
Product: Firefox → Toolkit
The new UI should resolve this.
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 893505
as i see, the new ui has not fixed it (or it was fixed and has been broken again).
Status: RESOLVED → UNCONFIRMED
Component: Application Update → General
OS: Unspecified → Windows 10
Product: Toolkit → Firefox
Hardware: Unspecified → x86_64
Resolution: DUPLICATE → ---
Version: 50 Branch → 63 Branch
as i see, the new ui has not fixed it (or it was fixed and has been broken again).
this is not duplicate of bug 893505, because its aim is:

"
warn users who are seriously out of date: if you are 12+ weeks out of date, we want to have semi-persistent warnings that you are running an insecure product

reduce users noticing updates. In the average case we don't want users to ever notice that Firefox was updated. In the edge cases we want updates to interrupt users as little as possible
"

but i say about notification immediately after update is downloaded and only restart is needed. so i propose something even opposite to that.

but i do not say about warning with dialog window popping up, but just a sign at toolbar, probably above main menu icon (3 short lines).

maybe there is already such sign in the program, i gave seen it somewhere, but seems it does not show up immediately after update is ready for program restart.
Component: General → Application Update
Product: Firefox → Toolkit

Based on user studies we don't want to be showing UI that informs the user that they have an update downloaded and they need to restart but we do want them to apply the update. So, for releases we display a badge on the "hamburger" menu after 4 days and prompt the user to restart using a "doorhanger" notification hanging off of the hamburger menu after 8 days. The days to wait for the badge notification is controlled by the app.update.badgeWaitTime preference and the "doorhanger" notification can be controlled by the app.update.promptWaitTime preference but this one needs to be set before the client received the update. We also have the ability to remotely change the amount of time before we show the "doorhanger" notification in case there is a critical fix included with the update.

Your use case is different than what we want (based on user studies) as the default. If you'd like it to behave differently you can use the preferences I noted above.

Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago11 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.