receiving messages fails to update unread/msg count and bold folder

VERIFIED DUPLICATE of bug 131769

Status

P1
normal
VERIFIED DUPLICATE of bug 131769
17 years ago
14 years ago

People

(Reporter: mythdraug, Assigned: Bienvenu)

Tracking

({regression})

Trunk
mozilla1.0
x86
All
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Build:  2002031903 Win32

Downloading new messages from a pop server fails to:
  1) Update new message count
  2) *BOLD* the folder

Asking for the next unread message will not cross folders.

However, the folder icon is changed to the new message here icon.

Comment 1

17 years ago
I'm seeing this consistently on mar19 commercial trunk, win98 and linux (haven't
done mac yet).  March14 trunk seems to work OK, regressed in past couple days.

Inbox doesn't update to bold, doesn't update message count until you reselect
the folder.  Still won't update/bold again after selecting, reading messages
then getting new ones.
Keywords: nsbeta1+, regression
QA Contact: esther → laurel
Summary: receiving messages fails to update many parts of folder status → POP: receiving messages fails to update unread/msg count and bold folder
(Reporter)

Comment 2

17 years ago
Any chance this was caused by the fix for bug 123550?

Updated

17 years ago
Priority: -- → P1
Target Milestone: --- → mozilla1.0
(Reporter)

Comment 3

17 years ago
*** Bug 132244 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 4

17 years ago
I've also seen the beavior described by hana in bug 132244.

Good screenshot from that bug:   
http://bugzilla.mozilla.org/showattachment.cgi?attach_id=75151
(Assignee)

Comment 5

17 years ago
I think there's a chance that the fix for bug 123550 did cause this - I'll try
it out. This happens with IMAP too, so it's not specific to POP.
Summary: POP: receiving messages fails to update unread/msg count and bold folder → receiving messages fails to update unread/msg count and bold folder
(Assignee)

Comment 6

17 years ago
I can't really reproduce this reliably enough to tell if the fix for bug 123550
is involved or not. It's also possible that this is related to bug 121660,
though this one did just start happening a few days ago. 

Comment 7

17 years ago
I see this with BuildID 2002031607 using both IMAP and POP on RedHat Linux 7.2.

BTW, sometimes (only saw this couple of times with POP) the counts would be
partially updated (e.g. to reflect 3 new messages when there are 10 of them)
which is extra confusing.
Keywords: mozilla1.0
OS: Windows 2000 → All

Comment 8

17 years ago
I haven't seen this using IMAP, but POP does this every single time.
(Assignee)

Comment 9

17 years ago
I see this even with backing out the fix for bug 123550, so that's not the cause.

Comment 10

17 years ago
Finally catching this on IMAP --After I switched to mar20 build, it's now
happening on my IMAP inbox.
(Assignee)

Comment 11

17 years ago
It's possible that the fix for bug 131769 will also fix this.
Assignee: sspitzer → bienvenu

Comment 12

17 years ago
Could this be related to bug 131595 "Local -> IMAP always copies instead of
moving (both D&D and "move to")"?
(Assignee)

Comment 13

17 years ago
I don't think the fix for bug 131769 will fix this, after all, and bug 131595 is
probably not related to either of these bugs.
(Assignee)

Comment 14

17 years ago
new fix for bug 131769 does fix this - duping.

*** This bug has been marked as a duplicate of 131769 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 15

17 years ago
*** Bug 131315 has been marked as a duplicate of this bug. ***

Comment 16

17 years ago
verified as duplicate.
Also, looks OK using mar22 commercial trunk: win98, mac OS 10.1, linux rh6.2
Status: RESOLVED → VERIFIED

Comment 17

16 years ago
This bug reappeared in several recent builds for Solaris 2.6. My latest build is
2002063022, and this bug is there.

Comment 18

16 years ago
I was not seeing this on Win98 2002061803.  Upgraded to 2002062908 and started
seeing it.  This isn't fixed and it doesn't seem like a dupe.

Comment 19

16 years ago
Another data point:  occasionally, the green arrow indicator on the folder will
not appear, even if that folder received new mail.  This is in addition to that
same folder name NOT appearing in bold, and the unread msg count NOT appearing.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.