[mach] Mach-o builds crash on startup

RESOLVED FIXED

Status

SeaMonkey
General
--
blocker
RESOLVED FIXED
17 years ago
14 years ago

People

(Reporter: zach, Assigned: Brian Ryner (not reading))

Tracking

({crash})

Trunk
PowerPC
Mac OS X
crash

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Using a mach-o build (opt) from this morning (the same one on ftp.m.o), I 
get a crash on startup. This looks like the same problem that the aol 
person was having. Setting to blocker as this is a blocker for me. I can 
post CrashReporter data, but I doubt it will do any good since it is an opt 
build, let me know if you want it.
(Reporter)

Comment 1

17 years ago
mach-o qa to me, owner to pinkerton for the moment
Assignee: asa → pinkerton
Keywords: crash
QA Contact: doronr → zach

Comment 2

17 years ago
Created attachment 75101 [details]
This is the Mozilla-bin.crash.log

Comment 3

17 years ago
Autoreg output. We're bailing on startup, and crashing on the way out.

[h-10-169-102-250:MozillaDebug.app/Contents/MacOS] smfr% ./mozilla-
bin
Type Manifest File: /Users/smfr/shared_macho/mozilla/dist/
MozillaDebug.app/Contents/MacOS/components/xpti.dat
nsNativeComponentLoader: autoregistering begins.
nsNativeComponentLoader: autoregistering succeeded
nNCL: registering deferred (0)
WARNING: NS_ENSURE_TRUE(NS_SUCCEEDED(rv)) failed, file 
nsAppStartupNotifier.cpp, line 66
###!!! ASSERTION: failed to get the appshell service: 
'NS_SUCCEEDED(rv)', file nsAppRunner.cpp, line 1256
###!!! Break: at file nsAppRunner.cpp, line 1256
Getting service on shutdown. Denied.
  ContractID: @mozilla.org/observer-service;1
         IID: {d07f5192-e3d1-11d2-8acd-00105a1b8860}
[h-10-169-102-250:MozillaDebug.app/Contents/MacOS] smfr% rm com
component.reg  components/    
[h-10-169-102-250:MozillaDebug.app/Contents/MacOS] smfr% rm 
component.reg 
[h-10-169-102-250:MozillaDebug.app/Contents/MacOS] smfr% ./mozilla-
bin
Type Manifest File: /Users/smfr/shared_macho/mozilla/dist/
MozillaDebug.app/Contents/MacOS/components/xpti.dat
nsNativeComponentLoader: autoregistering begins.
*** Registering nsAbSyncModule components (all right -- a generic 
module!)
*** Registering nsAccessibilityModule components (all right -- a generic 
module!)
*** Registering nsAbModule components (all right -- a generic module!)
nsGenericModule nsAbModule: Register hook for Address Book Startup 
Handler component returned error => 80004002
*** Registering application components (all right -- a generic module!)
nsGenericModule application: Register hook for Directory Viewer 
component returned error => 80004002
*** Registering nsAutoConfigModule components (all right -- a generic 
module!)
nsGenericModule nsAutoConfigModule: Register hook for ReadConfig 
Module component returned error => 80004002
*** Registering nsSecurityManagerModule components (all right -- a 
generic module!)
nsGenericModule nsSecurityManagerModule: Register hook for 
scriptsecuritymanager component returned error => 80004002
*** Registering nsCharDetModule components (all right -- a generic 
module!)
nsGenericModule nsCharDetModule: Register hook for Meta Charset 
component returned error => 80004002
*** Registering nsChromeModule components (all right -- a generic 
module!)
*** Registering nsComposerModule components (all right -- a generic 
module!)
*** Registering nsCookieModule components (all right -- a generic 
module!)
nsGenericModule nsCookieModule: Register hook for ImgManager 
component returned error => 80004002
*** Registering docshell_provider components (all right -- a generic 
module!)
*** Registering nsEditorModule components (all right -- a generic 
module!)
nsGenericModule nsEditorModule: Register hook for Editor Startup 
Handler component returned error => 80004002
*** Registering embedcomponents components (all right -- a generic 
module!)
*** Registering nsGfx2Module components (all right -- a generic module!)
*** Registering nsGfxModule components (all right -- a generic module!)
*** Registering nsGfxPSModule components (all right -- a generic 
module!)
*** Registering nsContentModule components (all right -- a generic 
module!)
nsGenericModule nsContentModule: Register hook for HTML img 
element component returned error => 80004005
*** Registering nsLayoutModule components (all right -- a generic 
module!)
*** Registering nsPluginModule components (all right -- a generic 
module!)
*** Registering nsViewModule components (all right -- a generic module!)
*** Registering nsParserModule components (all right -- a generic 
module!)
*** Registering nsBMPModule components (all right -- a generic module!)
*** Registering nsGIFModule2 components (all right -- a generic module!)
*** Registering nsJPEGDecoderModule components (all right -- a generic 
module!)
*** Registering nsImageLib2Module components (all right -- a generic 
module!)
*** Registering nsMNGDecoderModule components (all right -- a generic 
module!)
*** Registering nsPNGDecoderModule components (all right -- a generic 
module!)
*** Registering nsPPMDecoderModule components (all right -- a generic 
module!)
*** Registering nsImportServiceModule components (all right -- a generic 
module!)
*** Registering nsTextImportModule components (all right -- a generic 
module!)
*** ERROR: Problem registering Text Import component in the category 
manager
nsGenericModule nsTextImportModule: Register hook for Text Import 
Component component returned error => 80004002
*** Registering nsInspectorModule components (all right -- a generic 
module!)
*** Registering nsJarModule components (all right -- a generic module!)
*** Registering JavaScript_Debugger components (all right -- a generic 
module!)
*** Registering DOM_components components (all right -- a generic 
module!)
*** Registering JS_component_loader components (all right -- a generic 
module!)
nsGenericModule JS_component_loader: Register hook for JS 
component loader component returned error => 80004002
*** Registering javascript__protocol components (all right -- a generic 
module!)
*** Registering local_mail_services components (all right -- a generic 
module!)
*** Registering nsLWBrkModule components (all right -- a generic 
module!)
*** Registering nsMsgBaseModule components (all right -- a generic 
module!)
nsGenericModule nsMsgBaseModule: Register hook for Mail Startup 
Handler component returned error => 80004002
*** Registering mime_services components (all right -- a generic 
module!)
*** Registering nsMimeEmitterModule components (all right -- a generic 
module!)
nsGenericModule nsMimeEmitterModule: Register hook for HTML MIME 
Emitter component returned error => 80004002
*** Registering nsMorkModule components (all right -- a generic module!)
*** Registering nsBrowserModule components (all right -- a generic 
module!)
nsGenericModule nsBrowserModule: Register hook for Browser Startup 
Handler component returned error => 80004002
*** Registering nsFindComponent components (all right -- a generic 
module!)
*** Registering nsLDAPProtocolModule components (all right -- a generic 
module!)
*** Registering nsStreamTransferModule components (all right -- a 
generic module!)
*** Registering nsMsgComposeModule components (all right -- a generic 
module!)
nsGenericModule nsMsgComposeModule: Register hook for Msg 
Compose Startup Handler component returned error => 80004002
*** Registering nsMsgDBModule components (all right -- a generic 
module!)
*** Registering IMAP_factory components (all right -- a generic module!)
*** Registering nsMsgNewsModule components (all right -- a generic 
module!)
nsGenericModule nsMsgNewsModule: Register hook for News Startup 
Handler component returned error => 80004002
*** Registering necko_core_and_primary_protocols components (all right 
-- a generic module!)
nsGenericModule necko_core_and_primary_protocols: Register hook for 
nsStdURLParser component returned error => 80004002
*** Registering necko_secondary_protocols components (all right -- a 
generic module!)
*** Registering cacheservice components (all right -- a generic module!)
*** Registering appshell components (all right -- a generic module!)
*** Registering nsLocaleModule components (all right -- a generic 
module!)
*** Registering nsPrefMigrationModule components (all right -- a generic 
module!)
*** Registering nsCJVMManagerModule components (all right -- a generic 
module!)
*** Registering nsPrefModule components (all right -- a generic module!)
*** Registering nsProfileModule components (all right -- a generic 
module!)
*** Registering nsRDFModule components (all right -- a generic module!)
*** Registering nsRegistryViewerModule components (all right -- a 
generic module!)
*** Registering Session_History_Module components (all right -- a 
generic module!)
*** Registering nsSMIMEModule components (all right -- a generic 
module!)
*** Registering nsStringBundleModule components (all right -- a generic 
module!)
*** Registering TransformiixModule components (all right -- a generic 
module!)
nsGenericModule TransformiixModule: Register hook for XSLTProcessor 
component returned error => 80004002
*** Registering nsTransactionManagerModule components (all right -- a 
generic module!)
*** Registering nsTextServicesModule components (all right -- a generic 
module!)
*** Registering nsUConvModule components (all right -- a generic 
module!)
nsGenericModule nsUConvModule: Register hook for Charset 
Conversion Manager component returned error => 80004002
*** Registering nsUCvCnModule components (all right -- a generic 
module!)
nsGenericModule nsUCvCnModule: Register hook for Unicode Decoder-
GB2312 component returned error => 80004002
*** Registering nsUCvIBMModule components (all right -- a generic 
module!)
nsGenericModule nsUCvIBMModule: Register hook for Unicode Decoder-
IBM850 component returned error => 80004002
*** Registering nsUCvJAModule components (all right -- a generic 
module!)
nsGenericModule nsUCvJAModule: Register hook for Unicode Decoder-
Shift_JIS component returned error => 80004002
*** Registering nsUCvKoModule components (all right -- a generic 
module!)
nsGenericModule nsUCvKoModule: Register hook for Unicode Decoder-
EUC-KR component returned error => 80004002
*** Registering nsUCvLatinModule components (all right -- a generic 
module!)
nsGenericModule nsUCvLatinModule: Register hook for Unicode 
Decoder-us-ascii component returned error => 80004002
*** Registering nsUCvMathModule components (all right -- a generic 
module!)
nsGenericModule nsUCvMathModule: Register hook for Unicode 
Encoder-x-mathematica1 component returned error => 80004002
*** Registering nsUCvTWModule components (all right -- a generic 
module!)
nsGenericModule nsUCvTWModule: Register hook for Unicode Encoder-
Big5 component returned error => 80004002
*** Registering nsUCvTW2Module components (all right -- a generic 
module!)
nsGenericModule nsUCvTW2Module: Register hook for Unicode 
Decoder-x-euc-tw component returned error => 80004002
*** Registering UcharUtil components (all right -- a generic module!)
*** Registering nsURILoaderModule components (all right -- a generic 
module!)
*** Registering nsVCardModule components (all right -- a generic 
module!)
*** Registering nsWalletModule components (all right -- a generic 
module!)
nsGenericModule nsWalletModule: Register hook for Auto Form Fill and 
Wallet component returned error => 80004002
*** Registering nsWalletViewerModule components (all right -- a generic 
module!)
*** Registering Browser_Embedding_Module components (all right -- a 
generic module!)
nsGenericModule Browser_Embedding_Module: Register hook for 
nsIWebBrowserSetup content policy enforcer component returned error =
> 80004002
*** Registering nsWidgetModule components (all right -- a generic 
module!)
*** Registering nsXMLExtrasModule components (all right -- a generic 
module!)
nsGenericModule nsXMLExtrasModule: Register hook for XMLExtras 
component component returned error => 80004002
*** Registering xpconnect components (all right -- a generic module!)
*** Registering nsSoftwareUpdate components (all right -- a generic 
module!)
WARNING: NS_ENSURE_TRUE(NS_SUCCEEDED(rv)) failed, file 
nsSoftwareUpdate.cpp, line 605
nsGenericModule nsSoftwareUpdate: Register hook for SoftwareUpdate 
Component component returned error => 80004002
nsNativeComponentLoader: autoregistering succeeded
nNCL: registering deferred (0)
WARNING: NS_ENSURE_TRUE(NS_SUCCEEDED(rv)) failed, file 
nsAppStartupNotifier.cpp, line 66
###!!! ASSERTION: failed to get the appshell service: 
'NS_SUCCEEDED(rv)', file nsAppRunner.cpp, line 1256
###!!! Break: at file nsAppRunner.cpp, line 1256
Getting service on shutdown. Denied.
  ContractID: @mozilla.org/observer-service;1
         IID: {d07f5192-e3d1-11d2-8acd-00105a1b8860}
nsMenuX 0
nsMenuItemX 0

Comment 4

17 years ago
see bug 130954 for a discussion of crashing 
@nsComponentManagerImpl::FreeServices

as for the failures
nsGenericModule JS_component_loader: Register hook for JS 
component loader component returned error => 80004002
nsGenericModule nsBrowserModule: Register hook for Browser Startup 
Handler component returned error => 80004002
nsGenericModule necko_core_and_primary_protocols: Register hook for 
nsStdURLParser component returned error => 80004002
look to be the most interesting

Comment 5

17 years ago
It looks to me that those Registration Hook failures are because calls to get
the category manager service are failing.
over to smfr, since he's working on mach-o stuff right now and i'm swamped with
other embedding things. simon, punt it back if you want, i just figured with you
doing atsui stuff, you'd be the first to get to it.
Assignee: pinkerton → sfraser

Comment 7

17 years ago
The weird thing is that a clean build on my laptop worked. However, clobbering
and rebuilding my broken build on the G4 didn't make things any better. Nor did
adding --enable-strip.
(Reporter)

Comment 8

16 years ago
A completely clean build (the nightly up on ftp.m.o) also fails to work for 
me. I cannot get it to work using any build at all.

Comment 9

16 years ago
Pre-sabbatical bug triage. Maybe beard can figure this out, since he figured out
the previous IID linkage problems with the older compiler.
Assignee: sfraser → beard
(Reporter)

Comment 10

16 years ago
Some say this is gone, but I am still seeing it.

Comment 11

16 years ago
I did a clobber build, and this problem went away for me.  I'm about to do
another depend build to see if it comes back.  If it comes back, I'll comment
further.
(Reporter)

Comment 12

16 years ago
scc: are you building this in opt or debug? I don't think the problem occurs 
in debug, but I could be wrong.

Comment 13

16 years ago
Simon told me on Friday that he was inadvertently using old gcc tools.
(Reporter)

Comment 14

16 years ago
I think my gcc tools are current. I just did a distclean (at pink's insistance) 
and a build and it still crashes for me. I also removed my .mozilla folder. 
The build is almost on the ftp site now, if anyone else crashes using my 
build on their mac it should narrow it down to if the problem is in the build 
or in the running of the build.
Zach, I see the crash on startup when using your nightly builds but not with my
local builds using the same options.  (We went over this on IRC.)  Did you ever
manage to clear out enough space to do a -g build?

Another datapoint:  when I try to run xpcshell from Zach's nightly build, it
fails to init xpcom so it seems like something very basic is going wrong.

(gdb) r 
Starting program: /Users/cls/Mozilla.app/Contents/MacOS/./xpcshell 
[Switching to thread 1 (process 3195 thread 0x1903)]
Reading symbols for shared libraries
................................................. done
Reading symbols for shared libraries . done
NS_InitXPCOM failed!

Program exited with code 01.

In my build, there are several screenfuls of 'Reading symbols for shared
libraries' before it dumps the js component registration output and gives me a
xpcshell prompt.

Comment 16

16 years ago
I'm building a mach-o build myself right now, and will see if this is still a
problem.
(Reporter)

Comment 17

16 years ago
I just kicked off a new pull/build with the december tools reinstalled, will 
post results...

Comment 18

16 years ago
*** Bug 147360 has been marked as a duplicate of this bug. ***

Comment 19

16 years ago
I had been encountering this crash in Mach0 builds for many weeks.  Then
suddenly the May 9, 2002 Mach0 build worked and all builds since then have been
free of the problem.  I haven't spotted any comments about fixes directed at
this ... it's been one of those "went away" bugs.
 
Since no one has noted this, I thought a time stamp for when the problem stopped
would be useful.
 
Wish I could say the same for Chimera ... but they are working on it.

Dale

Comment 20

16 years ago
I have to add a counterpoint to me preceding message ... I spoke too soon it seems.  The MachO build from 5/31 resumed crashing after the splash screen had displayed for a while ... repeatably 100%

Now comes the 6/1 build and it's somewhat settled ... I have successfully run it for a while, but then had it "unexpectedly quit" following which I have been unsuccessful in getting it to go again.

There are changes affecting this going on, but I haven't discovered any comments that point to them.
 
Dale
(Assignee)

Comment 21

16 years ago
Can you get a crash log from this build?

Comment 22

16 years ago
Happening here again with the September 18 build. (Can't even get far enough to
see its build number.) Earlier Mach-O builds such as September 4 and September
11 launch fine, but this one stops while the icon bounces. Launching from the
command line gives:

[localhost:Mozilla.app/Contents/MacOS] fz% ./mozilla-bin 
dyld: ./mozilla-bin Undefined symbols:
/Volumes/Home/Applications/Mach-O.Sep18/Mozilla.app/Contents/MacOS/libmozjs.dylib
undefined reference to ___fegetfltrounds expected to be defined in
/usr/lib/libSystem.B.dylib



[localhost:Mozilla.app/Contents/MacOS] fz% gdb ./mozilla-bin 
GNU gdb 5.0-20001113 (Apple version gdb-203) (Wed Nov  7 16:28:57 GMT 2001) (UI_OUT)
Copyright 2000 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "powerpc-apple-macos10".

warning: Couldn't find library name in dyld_resolve_load_flag.

<above line repeated 15 times>

Reading symbols for shared libraries .. done
(gdb) continue
The program is not being run.
(gdb) 

  
(Assignee)

Comment 23

16 years ago
We recently updated the nightly build machine to 10.2, and the resulting builds
won't run on 10.1 until the patch in bug 165602 goes in on the trunk (which
should happen tomorrow).

Comment 24

16 years ago
over to bryner.
Assignee: beard → bryner

Updated

16 years ago
Depends on: 165602
(Assignee)

Comment 25

16 years ago
should be fixed now.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.