Closed Bug 13212 Opened 21 years ago Closed 21 years ago

Assertion when clicking the Customize button of the sidebar

Categories

(Core :: XUL, defect, P3)

x86
Linux
defect

Tracking

()

VERIFIED DUPLICATE of bug 12886

People

(Reporter: cls, Assigned: hyatt)

Details

I ran apprunner, opened the sidebar and clicked on the "Customize..." button.
Then I received screenfuls of
Assertion: "bad col frame" (PR_FALSE) at file
../../../../../layout/html/table/src/FixedTableLayoutStrategy.cpp, line 90

When I Ctrl-C'd out of it, I received this error:
Assertion: "datasource was never registered" (*hep != nsnull) at file
../../../../rdf/base/src/nsRDFService.cpp, line 860

When I attempted to reproduce the error, I did not get that final Ctrl-C error.
Here's the complete log..

cls@amadeus:bin>  ./mozilla-apprunner.sh
MOZILLA_FIVE_HOME=/opt/cls/mozilla/obj/dist/bin
  LD_LIBRARY_PATH=/opt/cls/mozilla/obj/dist/bin
      MOZ_PROGRAM=./apprunner
      MOZ_TOOLKIT=
        moz_debug=0
     moz_debugger=
nsNativeComponentLoader: autoregistering
/opt/cls/mozilla/obj/dist/bin/components
nsNativeComponentLoader: autoregistering succeeded
nsUnixToolkitService: Using 'gtk' for the Toolkit.
NS_SetupRegistry() MOZ_TOOLKIT=gtk, WIDGET_DLL=libwidget_gtk.so,
GFX_DLL=libgfx_gtk.so
GFX: dpi=100 t2p=0.0694444 p2t=14.4 depth=16
Using '/opt/cls/mozilla/obj/dist/bin' as the resource: base
Profile Manager : Command Line Options : Begin
Profile Manager : Command Line Options : End
Profile Manager : Profile Wizard and Manager activites : Begin
Profile Manager : Profile Wizard and Manager activites : End
ProfileName : mozProfile
ProfileDir  : /usr/home/cls/.mozilla/mozProfile
Initialized app shell component {4a85a5d0-cddd-11d2-b7f6-00805f05ffa5},
rv=0x00000000
XPInstall Component created
Initialized app shell component {18c2f989-b09f-11d2-bcde-00805f0e1353},
rv=0x00000000
Got the event queue from the service
Calling gdk_input_add with event queue
warning: property locale.all.ET_ET already exists
warning: property locale.all.ET_ET already exists
Note: frameverifytree is disabled
Note: verifyreflow is disabled
failed to get sidebar_pref
Doing navigator.js Startup...
Setting content window
browser.startup.page = 1
startpage = http://www.mozilla.org/
Document http://www.mozilla.org/ loaded successfully
Document: Done (1.75 secs)
Open it
got a request
got observer service
added observer
Init!
adding "http://cvs-mirror.mozilla.org/webtools/tinderbox/SeaMonkey/flash.rdf" to
the tree
http://cvs-mirror.mozilla.org/webtools/tinderbox/SeaMonkey/flash.rdf: setting
poll interval to 300sec.
adding "rdf:msgnotifications" to the tree
adding "rdf:xpinstall-update-notifier" to the tree
Block(div)(0)@0x89e0a00: Init: bad caller: width WAS 733968(0xb3310)
Block(div)(0)@0x89e0a00: WARNING: desired:733968,302
nsBlockReflowContext: Frame(hr)(0)@0x89e1de0 metrics=734026,200!
Block(div)(1)@0x89e1970: line=0x89e0ea8 xmost=734026
Block(div)(1)@0x89e1970: WARNING: desired:734026,200
Block(div)(2)@0x89e23a8: Init: bad caller: width WAS 733968(0xb3310)
Block(div)(2)@0x89e23a8: WARNING: desired:733968,230
nsBlockReflowContext: Frame(hr)(0)@0x89f02a0 metrics=734026,200!
Block(div)(4)@0x89f0240: line=0x89f02e8 xmost=734026
Block(div)(4)@0x89f0240: WARNING: desired:734026,200
Block(div)(5)@0x89f0328: Init: bad caller: width WAS 733968(0xb3310)
Block(div)(5)@0x89f0328: WARNING: desired:733968,230
nsBlockReflowContext: Frame(hr)(0)@0x89f8fd8 metrics=734026,200!
Block(div)(7)@0x89f91a0: line=0x89f8418 xmost=734026
Block(div)(7)@0x89f91a0: WARNING: desired:734026,200
Block(div)(0)@0x89e0a00: Init: bad caller: width WAS 733752(0xb3238)
Block(div)(0)@0x89e0a00: WARNING: desired:733752,302
nsBlockReflowContext: Frame(hr)(0)@0x89e1de0 metrics=733810,200!
Block(div)(1)@0x89e1970: line=0x89e0ea8 xmost=733810
Block(div)(1)@0x89e1970: WARNING: desired:733810,200
Block(div)(2)@0x89e23a8: Init: bad caller: width WAS 733752(0xb3238)
Block(div)(2)@0x89e23a8: WARNING: desired:733752,230
nsBlockReflowContext: Frame(hr)(0)@0x89f02a0 metrics=733810,200!
Block(div)(4)@0x89f0240: line=0x89f02e8 xmost=733810
Block(div)(4)@0x89f0240: WARNING: desired:733810,200
Block(div)(5)@0x89f0328: Init: bad caller: width WAS 733752(0xb3238)
Block(div)(5)@0x89f0328: WARNING: desired:733752,230
nsBlockReflowContext: Frame(hr)(0)@0x89f8fd8 metrics=733810,200!
Block(div)(7)@0x89f91a0: line=0x89f8418 xmost=733810
Block(div)(7)@0x89f91a0: WARNING: desired:733810,200
Assertion: "bad col frame" (PR_FALSE) at file
../../../../../layout/html/table/src/FixedTableLayoutStrategy.cpp, line 90
(Assertion repeated indefinitely)
Assignee: troy → karnaze
Component: Layout → HTMLTables
Assignee: karnaze → hyatt
David, can you look at this and if it is a table problem give it back to me.
Status: NEW → ASSIGNED
Component: HTMLTables → XUL
It's mine.
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
*** This bug has been marked as a duplicate of 12886 ***
Status: RESOLVED → VERIFIED
Agreed. This is a duplicate of 12886.
BULK MOVE: Changing component from XUL to XP Toolkit/Widgets: XUL.  XUL 
component will be deleted.
Component: XUL → XP Toolkit/Widgets: XUL
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: chrispetersen → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.