Screen artifacts while playing videos on youtube/twitch

REOPENED
Unassigned

Status

()

P3
major
REOPENED
2 years ago
a year ago

People

(Reporter: iulianm.ionescu, Unassigned, NeedInfo)

Tracking

({regressionwindow-wanted})

50 Branch
x86_64
Windows 7
regressionwindow-wanted
Points:
---

Firefox Tracking Flags

(platform-rel +)

Details

(Whiteboard: [platform-rel-Twitch][platform-rel-Youtube][gfx-noted])

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20161104212021

Steps to reproduce:

I was watching a video on YouTube.


Actual results:

At some point appeared some artifacts at top of the screen. First I thought it was my GPU, but I don't get any artifacts using Chrome or while playing games.


Expected results:

I shouldn't get those artifacts
(Reporter)

Comment 1

2 years ago
Created attachment 8815677 [details]
Video link

Video showing the problem
Post your Graphic section from about:support,
next make sure that you're using latest GPU drivers,
if not, update it and redo the STR and post info from about:support again.
Severity: normal → major
Component: Untriaged → Audio/Video: Playback
OS: Unspecified → Windows 7
Product: Firefox → Core
Hardware: Unspecified → x86_64
(Reporter)

Comment 3

2 years ago
Here is the printscreen of about:support, Graphics section: http://i.imgur.com/M3Cgz49.png
I have the latest driver for my GPU.
Thanks.
Status: UNCONFIRMED → NEW
Has Regression Range: --- → no
Has STR: --- → yes
Ever confirmed: true
Flags: needinfo?(iulianm.ionescu)
Keywords: regressionwindow-wanted
Mozilla/5.0 (Windows NT 6.1; rv:53.0) Gecko/20100101 Firefox/53.0

I could not reproduce this issue on Windows 7, tried using the latest Firefox 50 release and the latest Nightly 53. 

Iulian, have you  ever seen this issue on other Firefox versions prior to Firefox 50? Does this happen every time you watch a YouTube video or is this something intermittent? Would you be willing to try to narrow down the regression window? You can use the mozregression tool from:
http://mozilla.github.io/mozregression/

After seeing the video with the artifacts, this feels to be more a Graphics issue than a Video:Audio one. Anthony, could you please take a look?
Flags: needinfo?(iulianm.ionescu)
Flags: needinfo?(ajones)
(Reporter)

Comment 7

2 years ago
It started around Firfox 48 I think. It's quite random, but I would say if I watch a video for like 30min there is a 70% chance of it appearing. First I was thinking the same, a graphics card issue, but I don't get this problem using Chrome and I play games, quite graphical intensive ones, and don't have any kind of problems. I've even tried OCCT as stress test to see if those artifacts are coming up and nothing. This only happens while using Firefox and watching videos on Youtube or Twitch.

Could be something related to AMD gpu drivers, there was a time when you'd get graphical artifacts on the interface of Firefox and disabling Hardware Acceleration was fixing that problem back then, but it was fixed at some point. I've tried doing the same now, but still I get those artifacts.

I must say I'm not familiar with Mozgression tool.
(In reply to Simona B [:simonab ] from comment #6)
> After seeing the video with the artifacts, this feels to be more a Graphics
> issue than a Video:Audio one. Anthony, could you please take a look?

It looks like a graphics issue to me.
Component: Audio/Video: Playback → Graphics
Flags: needinfo?(ajones)
(Reporter)

Comment 9

2 years ago
Just wanted to let you guys know that now I'm running Firefox 50.0.2 and I've installed the latest AMD driver that was released like 2 days ago which included some fixes for Firefox. It seems to work fine, no artifacts. I'll keep you updated if they appear but it seems to be fixed.
Per Comment 9 marking as WFM.
Reopen if it will happen again.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 11

2 years ago
Seems the problem came back while watching Twitch for a few hours. My initial testing was with Youtube and didn't had problems until now. Feels like Twitch is causing this problem, might be something related to their implementation of HTML5.

Nothing changed from last time in terms of drivers or add-ons.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 12

2 years ago
(In reply to Iulian Ionescu from comment #11)
> Seems the problem came back while watching Twitch for a few hours. My
> initial testing was with Youtube and didn't had problems until now. Feels
> like Twitch is causing this problem, might be something related to their
> implementation of HTML5.
> 
> Nothing changed from last time in terms of drivers or add-ons.

Have you tried disabling hardware acceleration?
(Reporter)

Comment 13

2 years ago
(In reply to Sean Adams from comment #12)
> (In reply to Iulian Ionescu from comment #11)
> > Seems the problem came back while watching Twitch for a few hours. My
> > initial testing was with Youtube and didn't had problems until now. Feels
> > like Twitch is causing this problem, might be something related to their
> > implementation of HTML5.
> > 
> > Nothing changed from last time in terms of drivers or add-ons.
> 
> Have you tried disabling hardware acceleration?

I've tried that and still got the artifcats. Btw, could be the fact that I enabled Electrolysis?
I set:
browser.tabs.remote.autostart to true
extensions.e10sBloc­kedByAddons to false
extensions.e10sBloc­ksEnabling to false
platform-rel: --- → ?
Whiteboard: [platform-rel-Twitch][platform-rel-Youtube]
Milan, a GPU issue?
platform-rel: ? → +
Flags: needinfo?(milan)
This looks like an actual hardware issue, yes.  Probably seeing it with movies and Firefox more because we're using more graphics memory.
Flags: needinfo?(milan)
Priority: -- → P3
Whiteboard: [platform-rel-Twitch][platform-rel-Youtube] → [platform-rel-Twitch][platform-rel-Youtube][gfx-noted]
You need to log in before you can comment on or make changes to this bug.