Closed Bug 1321259 Opened 3 years ago Closed 3 years ago

Border-image only renders corners when a nine-sliced SVG source is used

Categories

(Firefox :: Untriaged, defect)

50 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1315353

People

(Reporter: r.otten, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20161123182536

Steps to reproduce:

Authored a piece of HTML and CSS which contains a block element with a border-image set to a nine-sliced SVG source that should be rounded to fit along the borders.

i.e. https://jsfiddle.net/606vd4xg/1/



Actual results:

Firefox only displays the border image in the 4 corners. It fails to display it for the connecting borders.


Expected results:

Firefox should have displayed the border image properly.
This seems to be fixed on beta51.

@Reporter
Could you test this on Beta51[1]?

[1]
https://www.mozilla.org/en-US/firefox/channel/desktop/
Flags: needinfo?(r.otten)
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1315353
Don't have beta 51, but I can verify that my test case looks fixed in developer edition, from which I gather the patch to 51 mentioned in #1315353 originated.
Flags: needinfo?(r.otten)
You need to log in before you can comment on or make changes to this bug.