Intermittent devtools/client/netmonitor/test/browser_net_accessibility-01.js | leaked 2 window(s) until shutdown [url = about:blank]

RESOLVED DUPLICATE of bug 1309866

Status

DevTools
Netmonitor
RESOLVED DUPLICATE of bug 1309866
2 years ago
a month ago

People

(Reporter: Treeherder Bug Filer, Unassigned)

Tracking

({intermittent-failure})

unspecified
intermittent-failure
Bug Flags:
qe-verify -

Firefox Tracking Flags

(Not tracked)

Details

Priority: -- → P3

Comment 1

2 years ago
21 failures in 133 pushes (0.158 failures/push) were associated with this bug yesterday.  

Repository breakdown:
* mozilla-inbound: 10
* autoland: 8
* mozilla-central: 3

Platform breakdown:
* linux32: 21

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1321436&startday=2016-12-01&endday=2016-12-01&tree=all
this is pretty much a perma fail, here is the range where it started:
https://treeherder.mozilla.org/#/jobs?repo=autoland&filter-searchStr=Linux%20debug%20Mochitest%20Mochitest%20DevTools%20Browser%20Chrome%20M(dt6)&fromchange=079ee7b41c3a5c33e1608c01ebaf17751f41d5f9&tochange=e36b4963793fe08d4c6f7d02a6fe753a72a0c86a

* note: dt6 is perma fail for other reasons, but somewhere in these two pushes we started failing on net filter and then leaking:
https://hg.mozilla.org/integration/autoland/pushloghtml?changeset=dc202d732d64 <- I suspect this one
https://hg.mozilla.org/integration/autoland/pushloghtml?changeset=fcabe39c665f

I found this out when looking at windows 7 tests in a new VM environment- so this seems to fail elsewhere, just not in our standard automation.

since this is basically a perma fail, I would like to get attention to this bug sooner than later.  Since this fails on linux32, we only run tests every ~5th push.  If you look at 21 failures in 133 pushes, that translates to more like 100 failures in 133 pushes- which is a very high failure rate!

:daisuke, can you take a look at this?
Flags: needinfo?(daisuke)
Looking at it another way, the test was just changed in bug 1309866 - that might be responsible.
Flags: needinfo?(jsnajdr)

Comment 4

2 years ago
30 failures in 87 pushes (0.345 failures/push) were associated with this bug yesterday.  

Repository breakdown:
* mozilla-inbound: 17
* autoland: 10
* mozilla-central: 3

Platform breakdown:
* linux32: 28
* windows8-64: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1321436&startday=2016-12-02&endday=2016-12-02&tree=all

Comment 5

2 years ago
62 failures in 694 pushes (0.089 failures/push) were associated with this bug in the last 7 days. 

This is the #12 most frequent failure this week. 

** This failure happened more than 50 times this week! Resolving this bug is a high priority. **

Repository breakdown:
* mozilla-inbound: 28
* autoland: 25
* mozilla-central: 9

Platform breakdown:
* linux32: 60
* windows8-64: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1321436&startday=2016-11-28&endday=2016-12-04&tree=all
Seems likely, since it stopped failing when that was backed out.
Blocks: 1309866
Flags: needinfo?(jsnajdr)
Flags: needinfo?(daisuke)

Updated

2 years ago
Blocks: 1307743
Priority: P3 → --
Whiteboard: [netmonitor] [triage]

Updated

2 years ago
Flags: qe-verify-
Priority: -- → P3
Whiteboard: [netmonitor] [triage] → [netmonitor-reserve]
Fixed as part of bug 1309866, before it was re-landed.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1309866

Updated

2 years ago
No longer blocks: 1307743
Priority: P3 → --
Whiteboard: [netmonitor-reserve]

Updated

a month ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.