Autoland should actively notice user if it fails to land the changesets

RESOLVED DUPLICATE of bug 1318402

Status

Conduit
Transplant
RESOLVED DUPLICATE of bug 1318402
2 years ago
2 months ago

People

(Reporter: xidorn, Unassigned)

Tracking

Details

(Reporter)

Description

2 years ago
Currently, autoland only shows an error in MozReview if it fails to rebase the patch because of conflicts. However, since it could take a while between one pushes the button and it actually tries to land, people may just push the button and never check it again after. When a conflict happens, the reviewed patches may then be left unlanded forever.

I suggest that we should have a bot to comment in the bug or send an email to the person who triggers the landing when autoland fails.

Alternatively, we could add a bot to scan bugzilla regularly and notify people about any reviewed but unlanded patch. (Actually last week I found a patch which was reviewed 10 years ago but left unlanded until I came across the same bug again.) I think it is pretty easy to forget landing reviewed patches in our general workflow.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1318402

Updated

2 months ago
Product: MozReview → Conduit
You need to log in before you can comment on or make changes to this bug.