Intermittent dom/media/test/test_bug448534.html | Test timed out.

RESOLVED DUPLICATE of bug 1317234

Status

()

Core
Audio/Video
RESOLVED DUPLICATE of bug 1317234
a year ago
19 hours ago

People

(Reporter: Treeherder Bug Filer, Unassigned)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
treeherder
Filed by: philringnalda [at] gmail.com

https://treeherder.mozilla.org/logviewer.html#?job_id=7556633&repo=autoland

https://archive.mozilla.org/pub/firefox/tinderbox-builds/autoland-macosx64-debug/1480564724/autoland_yosemite_r7-debug_test-mochitest-media-bm107-tests1-macosx-build207.txt.gz
(In reply to Treeherder Bug Filer from comment #0)
> Filed by: philringnalda [at] gmail.com
> 
> https://treeherder.mozilla.org/logviewer.html#?job_id=7556633&repo=autoland
> 
> https://archive.mozilla.org/pub/firefox/tinderbox-builds/autoland-macosx64-
> debug/1480564724/autoland_yosemite_r7-debug_test-mochitest-media-bm107-
> tests1-macosx-build207.txt.gz

Thread 37
0  libsystem_kernel.dylib!__psynch_mutexwait + 0xa
   rax = 0x000000000200012d   rdx = 0x0000000000103000
   rcx = 0x000000011a33fe98   rbx = 0x0000000000103203
   rsi = 0x0000000000103203   rdi = 0x0000000125ba3528
   rbp = 0x000000011a33ff20   rsp = 0x000000011a33fe98
    r8 = 0x0000000000002060    r9 = 0x000000011a12b540
   r10 = 0x00000000000024e7   r11 = 0x0000000000000246
   r12 = 0x0000000125ba3540   r13 = 0x0000000000103203
   r14 = 0x0000000000103000   r15 = 0x0000000125ba3528
   rip = 0x00007fff890b4166
   Found by: given as instruction pointer in context
1  CoreAudio!HALB_Mutex::Lock() + 0x2b
   rbp = 0x000000011a33ff40   rsp = 0x000000011a33ff30
   rip = 0x00007fff8b7aaa5b
   Found by: previous frame's frame pointer
2  CoreAudio!HALC_ProxyIOContext::SetPropertyData(AudioObjectPropertyAddress const&, unsigned int, void const*, unsigned int, void const*) + 0x95
   rbp = 0x000000011a33ffc0   rsp = 0x000000011a33ff50
   rip = 0x00007fff8b7cb80b
   Found by: previous frame's frame pointer
3  CoreAudio!HALC_ShellObject::SetPropertyData(unsigned int, AudioObjectPropertyAddress const&, unsigned int, void const*, unsigned int, void const*) + 0x22b
   rbp = 0x000000011a340110   rsp = 0x000000011a33ffd0
   rip = 0x00007fff8b7c7635
   Found by: previous frame's frame pointer
4  CoreAudio!HAL_HardwarePlugIn_ObjectSetPropertyData(AudioHardwarePlugInInterface**, unsigned int, AudioObjectPropertyAddress const*, unsigned int, void const*, unsigned int, void const*) + 0x89
   rbp = 0x000000011a340160   rsp = 0x000000011a340120
   rip = 0x00007fff8b7c73ee
   Found by: previous frame's frame pointer
5  CoreAudio!HALPlugIn::ObjectSetPropertyData(HALObject const&, AudioObjectPropertyAddress const&, unsigned int, void const*, unsigned int, void const*, AudioTimeStamp const*) + 0x2d
   rbp = 0x000000011a340190   rsp = 0x000000011a340170
   rip = 0x00007fff8b7c72c1
   Found by: previous frame's frame pointer
6  CoreAudio!HALObject::SetPropertyData(AudioObjectPropertyAddress const&, unsigned int, void const*, unsigned int, void const*, AudioTimeStamp const*) + 0x94
   rbp = 0x000000011a3401e0   rsp = 0x000000011a3401a0
   rip = 0x00007fff8b7c8fc8
   Found by: previous frame's frame pointer
7  CoreAudio!AudioDeviceSetProperty + 0x161
   rbp = 0x000000011a340260   rsp = 0x000000011a3401f0
   rip = 0x00007fff8b7d61b3
   Found by: previous frame's frame pointer
8  CoreAudio + 0xe3b0
   rbp = 0x000000011a3402d0   rsp = 0x000000011a340270
   rip = 0x00000001381d13b0
   Found by: previous frame's frame pointer
9  CoreAudio + 0xdcb7
   rbp = 0x000000011a340300   rsp = 0x000000011a3402e0
   rip = 0x00000001381d0cb7
   Found by: previous frame's frame pointer
0  CoreAudio + 0x8751
   rbp = 0x000000011a340340   rsp = 0x000000011a340310
   rip = 0x00000001381cb751
   Found by: previous frame's frame pointer
1  CoreAudio + 0xc6e1
   rbp = 0x000000011a340360   rsp = 0x000000011a340350
   rip = 0x00000001381cf6e1
   Found by: previous frame's frame pointer
2  CoreAudio + 0x36b6
   rbp = 0x000000011a340380   rsp = 0x000000011a340370
   rip = 0x00000001381c66b6
   Found by: previous frame's frame pointer
3  CoreAudio + 0xbae46
   rbp = 0x000000011a3403b0   rsp = 0x000000011a340390
   rip = 0x000000013827de46
   Found by: previous frame's frame pointer
4  XUL!setup_audiounit_stream [cubeb_audiounit.cpp:079ee7b41c3a : 1446 + 0x5]
   rbp = 0x000000011a3404b0   rsp = 0x000000011a3403c0
   rip = 0x000000010b950b4b
   Found by: previous frame's frame pointer
5  XUL!audiounit_stream_init [cubeb_audiounit.cpp:079ee7b41c3a : 1526 + 0x8]
   rbx = 0x0000000125fca2c8   rbp = 0x000000011a340510
   rsp = 0x000000011a3404c0   r12 = 0x0000000000000000
   r13 = 0x000000010a001740   r14 = 0x000000000000113a
   r15 = 0x0000000125fca200   rip = 0x000000010b94de1e
   Found by: call frame info
6  XUL!mozilla::AudioStream::OpenCubeb(cubeb*, cubeb_stream_params&, mozilla::TimeStamp, bool) [AudioStream.cpp:079ee7b41c3a : 370 + 0x40]
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1317234

Comment 2

a year ago
5 failures in 526 pushes (0.01 failures/push) were associated with this bug in the last 7 days.  

Repository breakdown:
* autoland: 4
* mozilla-inbound: 1

Platform breakdown:
* osx-10-10: 5

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1321483&startday=2016-12-12&endday=2016-12-18&tree=all

Comment 3

19 hours ago
7 failures in 889 pushes (0.008 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* mozilla-inbound: 4
* autoland: 2
* mozilla-central: 1

Platform breakdown:
* android-6-0-armv8-api16: 7

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1321483&startday=2017-12-04&endday=2017-12-10&tree=all
You need to log in before you can comment on or make changes to this bug.