Closed Bug 1321506 Opened 5 years ago Closed 5 years ago

ZERO WIDTH NON-JOINER (U+200C) character shortcut (Ctrl+Shift+2) not work in new Firefox update

Categories

(Core :: Widget: Win32, defect)

50 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1318972

People

(Reporter: greensimpleid, Assigned: masayuki)

Details

(Keywords: rtl)

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20161129173726

Steps to reproduce:

ZERO WIDTH NON-JOINER (U+200C) character "Shortcut" (Ctrl+Shift+2) not work in right to left languages (like Persian) at new Firefox update. (Now works at Google Chrome)

Additional information: In Farsi language, there is a character called half-space which acts like space but doesn't actually creates a space between to characters. Example is shown in the attachment)

Here is a text with half-space:
می‌نویسم
Here is a text with normal space:
می نویسم

(https://bugzilla.mozilla.org/show_bug.cgi?id=684148)


Actual results:

"Ctrl+Shift+2" shortcut not work for half space at RTL languages (like Farsi)


Expected results:

Half Space "Ctrl+Shift+2" shortcut work just like before and other browsers
"Ctrl+Shift+2" and "Ctrl+Shift+@" shortcuts are identical
Flags: needinfo?(greensimpleid)
I reproduce this on
 - Release 50.0 
User agent:Mozilla/5.0 (Windows NT 6.1; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0
                BuildID 20161104212021
 - Release 50.0.2: User Agent Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:50.0) Gecko/20100101 Firefox/50.0
                   BuildID 20161129173726

Not reproducible on 
 - latest Nightly53.0a1 User Agent Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:53.0) Gecko/20100101 Firefox/53.0
                        Build ID 20161205030204
 - Release 49.0.2 User Agent Mozilla/5.0 (Windows NT 6.1; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0
                  Build ID 	20161019084923
Component: Untriaged → General
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64
Status: UNCONFIRMED → NEW
Ever confirmed: true
(In reply to Brindusa Tot[:brindusat] from comment #2)
> I reproduce this on
>  - Release 50.0 
> User agent:Mozilla/5.0 (Windows NT 6.1; WOW64; rv:50.0) Gecko/20100101
> Firefox/50.0
>                 BuildID 20161104212021
>  - Release 50.0.2: User Agent Mozilla/5.0 (Windows NT 6.1; Win64; x64;
> rv:50.0) Gecko/20100101 Firefox/50.0
>                    BuildID 20161129173726
> 
> Not reproducible on 
>  - latest Nightly53.0a1 User Agent Mozilla/5.0 (Windows NT 6.1; Win64; x64;
> rv:53.0) Gecko/20100101 Firefox/53.0
>                         Build ID 20161205030204
>  - Release 49.0.2 User Agent Mozilla/5.0 (Windows NT 6.1; WOW64; rv:49.0)
> Gecko/20100101 Firefox/49.0
>                   Build ID 	20161019084923

Can you find a regression and/or fix window?
Component: General → Untriaged
Flags: needinfo?(brindusa.tot)
Keywords: rtl
Sounds like this is a dup of bug 1318972 (fixed by bug 1303273 and the bugs which blocks the bug).

Do you reproduce this bug with Developer Edition? <https://www.mozilla.org/en-US/firefox/channel/desktop/>

If it works, unfortunately, we need to wait release of 52 because I don't have idea to fix this with minimum patch which is enough safe to uplift to Beta (at least for now, I'm afraid that writing some patches for Beta might cause break other keyboard layout's input because our keyboard layout handling at inputting text was really wrong). Of course, probably I understand how this is critical for same keyboard layout users...
Re-tested this bug and I reproduced it on Nightly 52.0a1.
- Last Nightly build this is reproducible is from 2016-10-11, Build ID  20161011030247
- First Nightly build this is NOT reproducible is from 2016-10-12, build ID 20161012030047

The push log obtained with the fix is: 
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=7ae377917236b7e6111146aa9fb4c073c0efc7f4&tochange=feb1c52ebe9ef8cff09dea275aa06d9441f5fe93

Bug 1303273, mentioned in comment 4, is included in this push log.
Flags: needinfo?(brindusa.tot)
(In reply to Masayuki Nakano [:masayuki] (Mozilla Japan) from comment #4)
> Sounds like this is a dup of bug 1318972 (fixed by bug 1303273 and the bugs
> which blocks the bug).
> 
> Do you reproduce this bug with Developer Edition?
> <https://www.mozilla.org/en-US/firefox/channel/desktop/>

This is also reproducible on Aurora 51.0a2 build ID 20161101004006.
Note that this bug is NOT reproducible on latest Aurora build 52.0a2, build ID 20161207004003

All tests, on Aurora and Nightly were performed on Windows7 x64bit.
Thank you for your test. I'm surprised at still reproducing this kind of bugs with 52~ because it handles native text input events on Windows without any hack. I'll investigate this next week.
Assignee: nobody → masayuki
Component: Untriaged → Widget: Win32
Product: Firefox → Core
Oops, I misunderstood comment 5. This becomes not reproduced around bug 1303273 fix. So, this should be fixed by bug 1303273 as I expected.
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(greensimpleid)
Resolution: --- → DUPLICATE
Duplicate of bug: 1318972
You need to log in before you can comment on or make changes to this bug.