Re-enable GPU process when webrender is enabled

RESOLVED FIXED in mozilla54

Status

()

Core
Graphics: WebRender
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: sotaro, Assigned: kats)

Tracking

(Blocks: 1 bug)

unspecified
mozilla54
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
GPU process is disabled by Bug 1321501. We need to re-enable it again.
(Reporter)

Updated

a year ago
Blocks: 1321501
(Reporter)

Updated

a year ago
No longer blocks: 1321501
(Reporter)

Updated

a year ago
Blocks: 1311790
Summary: Re-enable GPU process → Re-enable GPU process when webrender is enabled

Updated

a year ago
Depends on: 1323799
Assignee: nobody → bugmail
Try is obviously green but when I ran the windows QR build locally it seemed be quite crashy. I'm going to build it locally and debug.
Of course when I try and debug the crashiness with Visual Studio I can't reproduce the problems. I'll try some more later.
I think the issues I was seeing are the same ones Sotaro filed bug 1331828 and bug 1331847 for, and are not specific to GPU process enabling. So this should be good to land.

Comment 5

a year ago
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/projects/graphics/rev/bb1c3df4a7f6
Re-enable using the GPU process for WebRender. r=gfx?
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla54
You need to log in before you can comment on or make changes to this bug.