very frequent beachball and freezing

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: Robert, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20161123182536

Steps to reproduce:

When opening any page in Firefox and when typing text in a form (like this one)


Actual results:

beachball for 15 or more seconds...or non-stop. Most of the time I have to force-quit. This does only happen in Firefox, not in Safari or any app.


Expected results:

Just work as it used to work
(Reporter)

Updated

2 years ago
OS: Unspecified → iOS 10

Updated

2 years ago
Component: Untriaged → Browser
Product: Firefox → Firefox for iOS
Version: 50 Branch → unspecified
(Reporter)

Comment 1

2 years ago
Is this supposed to be an answer or a solution?

Updated

2 years ago
Component: Browser → Untriaged
Product: Firefox for iOS → Firefox
(Reporter)

Comment 2

2 years ago
I don't understand why I get emails but there are no answers to the problem

Comment 3

2 years ago
Hi Robert. I'm not able to reproduce this with Firefox 50.0.2 on OSX 10.12.1, nor with the latest Firefox Nightly version.
 
1. Can you confirm you're still having this problem with the latest version of Firefox? 
2. Can you confirm whether you're seeing this on OS X desktop or on iOS? There seems to be a bit of confusion maybe about that, based on activity of this bug.

Comment 4

2 years ago
(In reply to Michael Downey from comment #3)

Sorry, forgot to add in my previous comment:

bugday-20161205
(Reporter)

Comment 5

2 years ago
Michael 
I use the latest Firefox as confirmed in Firefox 50.0.2 "Firefox is up to date".
No idea what Firefox Nightly version is.
I stated I use MacOS 10.12.1 (which is for desktops), so it is not iOS.

Yes, I still have the same problem with Firefox, not with Safari.
Firefox uses 10-15x more memory than Safari with exactly the same windows open.
(Reporter)

Comment 6

2 years ago
I keep on getting emails with a link to an reply to this bug, but there are no replies.
Annoying
Hi Robert,

I'm trying to reproduce your issue but I lack some information. I'm using a MacBook Pro with Mac OS 10.12 and I've tried several sites where you have to either use a form to log in or to sign up and I haven't encountered any of the mentioned issues. Tested with Firefox 50.0 and latest 50.0.2 builds.

Are you having this issue with a specific website or on any website ? If this happens on any website can you retest this using a new Firefox profile (step 7 - https://goo.gl/PNe90E). Maybe some add-ons or custom settings are affecting the functionality in some way.

Also, I'm curious what extensions you have installed. Maybe one of them is creating this issues. Can you send me a copy of the about:support page (https://goo.gl/Uxw9UU)? I'll try to install some of them to see if any of them is causing this.
Flags: needinfo?(chaver4u)
OS: iOS 10 → Mac OS X
Hardware: Unspecified → x86_64
(Reporter)

Comment 8

2 years ago
(In reply to Paul Oiegas [:pauloiegasSV] from comment #7)
> Hi Robert,
> 
> I'm trying to reproduce your issue but I lack some information. I'm using a
> MacBook Pro with Mac OS 10.12 and I've tried several sites where you have to
> either use a form to log in or to sign up and I haven't encountered any of
> the mentioned issues. Tested with Firefox 50.0 and latest 50.0.2 builds.
> 
> Are you having this issue with a specific website or on any website ? If
> this happens on any website can you retest this using a new Firefox profile
> (step 7 - https://goo.gl/PNe90E). Maybe some add-ons or custom settings are
> affecting the functionality in some way.

I assume it's the cause. Without add-ons no beachball and all sites open much faster
> 
> Also, I'm curious what extensions you have installed. Maybe one of them is
> creating this issues. Can you send me a copy of the about:support page
> (https://goo.gl/Uxw9UU)? I'll try to install some of them to see if any of
> them is causing this.

Here the copy:

Application Basics
------------------

Name: Firefox
Version: 50.0.2
Build ID: 20161129173726
Update Channel: release
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:50.0) Gecko/20100101 Firefox/50.0
OS: Darwin 16.1.0
Multiprocess Windows: 0/1 (Disabled by add-ons)
Safe Mode: false

Crash Reports for the Last 3 Days
---------------------------------

All Crash Reports

Extensions
----------

Name: 1Password
Version: 4.6.2
Enabled: true
ID: onepassword4@agilebits.com

Name: 1Password Beta
Version: 4.4.3.b2
Enabled: true
ID: onepassword4-beta@agilebits.com

Name: Adblock Plus
Version: 2.8.2
Enabled: true
ID: {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}

Name: Application Update Service Helper
Version: 1.0
Enabled: true
ID: aushelper@mozilla.org

Name: Auto-Sort Bookmarks
Version: 2.10.9
Enabled: true
ID: sortbookmarks@bouanto

Name: Bookmarks Checker - check for bad links
Version: 5.8.1
Enabled: true
ID: firefoxbookmarkchecker@everhelper.me

Name: ColorfulTabs
Version: 31.0.9
Enabled: true
ID: {0545b830-f0aa-4d7e-8820-50a4629a56fe}

Name: Email Link button
Version: 0.9.1-signed.1-signed
Enabled: true
ID: {2A638E17-DE1D-48d3-A4B7-39E9670FF77A}

Name: Hola Better Internet
Version: 1.22.550
Enabled: true
ID: jid1-4P0kohSJxU1qGg@jetpack

Name: Multi-process staged rollout
Version: 1.5
Enabled: true
ID: e10srollout@mozilla.org

Name: NetVideoHunter
Version: 1.20
Enabled: true
ID: netvideohunter@netvideohunter.com

Name: Pocket
Version: 1.0.5
Enabled: true
ID: firefox@getpocket.com

Name: Print Edit
Version: 17.5
Enabled: true
ID: printedit@DW-dev

Name: Restartless Restart
Version: 9.1-signed.1-signed
Enabled: true
ID: restartless.restart@erikvold.com

Name: Share Button for Facebook™
Version: 49.1
Enabled: true
ID: {d4e0dc9c-c356-438e-afbe-dca439f4399d}

Name: Share on Twitter
Version: 0.50.0
Enabled: true
ID: jid1-SmvuJ9Cq3Cx13w@jetpack

Name: Shortly URL Shortner
Version: 2.1
Enabled: true
ID: shortly@aloshbennett.in

Name: TinEye Reverse Image Search
Version: 1.2.2
Enabled: true
ID: tineye@ideeinc.com

Name: Undo Closed Tabs Button
Version: 4.0.1
Enabled: true
ID: undoclosedtabsbutton@supernova00.biz

Name: Web Compat
Version: 1.0
Enabled: true
ID: webcompat@mozilla.org

Graphics
--------

Features
Compositing: OpenGL
Asynchronous Pan/Zoom: none
WebGL Renderer: Intel Inc. -- Intel(R) Iris(TM) Graphics 6100
WebGL2 Renderer: (no info)
Hardware H264 Decoding: Yes
Audio Backend: audiounit
GPU #1
Active: Yes
Vendor ID: 0x8086
Device ID: 0x162b

Diagnostics
AzureCanvasAccelerated: 1
AzureCanvasBackend: skia
AzureContentBackend: skia
AzureFallbackCanvasBackend: none
TileHeight: 1024
TileWidth: 1024





Important Modified Preferences
------------------------------

accessibility.blockautorefresh: true
accessibility.typeaheadfind.flashBar: 0
browser.cache.disk.capacity: 358400
browser.cache.disk.filesystem_reported: 1
browser.cache.disk.smart_size.first_run: false
browser.cache.disk.smart_size.use_old_max: false
browser.cache.frecency_experiment: 2
browser.download.importedFromSqlite: true
browser.places.smartBookmarksVersion: 8
browser.privatebrowsing.autostart: true
browser.sessionstore.upgradeBackup.latestBuildID: 20161129173726
browser.startup.homepage: http://globalstrategists.com/
browser.startup.homepage_override.buildID: 20161129173726
browser.startup.homepage_override.mstone: 50.0.2
browser.tabs.loadInBackground: false
browser.tabs.remote.autostart.2: true
browser.urlbar.userMadeSearchSuggestionsChoice: true
dom.apps.lastUpdate.buildID: 20161019084923
dom.apps.lastUpdate.mstone: 49.0.2
dom.apps.reset-permissions: true
dom.max_script_run_time: 0
dom.mozApps.used: true
dom.push.userAgentID: 357c8e46975f4eec88aeafc65f8714aa
extensions.lastAppVersion: 50.0.2
font.internaluseonly.changed: false
font.name.serif.x-western: Roboto
gfx.blacklist.direct2d.failureid: FEATURE_FAILURE_DL_BLACKLIST_g984
gfx.crash-guard.glcontext.appVersion: 45.0.2
gfx.crash-guard.glcontext.deviceID: 0x162b
gfx.crash-guard.status.glcontext: 2
media.benchmark.vp9.fps: 102
media.benchmark.vp9.versioncheck: 1
media.gmp-gmpopenh264.abi: x86_64-gcc3-u-i386-x86_64
media.gmp-gmpopenh264.lastUpdate: 1471461593
media.gmp-gmpopenh264.version: 1.6
media.gmp-manager.buildID: 20161129173726
media.gmp-manager.lastCheck: 1480969066
media.gmp-widevinecdm.abi: x86_64-gcc3-u-i386-x86_64
media.gmp-widevinecdm.lastUpdate: 1474829423
media.gmp-widevinecdm.version: 1.4.8.903
media.gmp.storage.version.observed: 1
media.webrtc.debug.aec_log_dir: /Users/robertbarzelay/Library/Caches/TemporaryItems
media.webrtc.debug.log_file: /Users/robertbarzelay/Library/Caches/TemporaryItems/WebRTC.log
media.youtube-ua.override.to: 43
network.auth.allow-subresource-auth: 2
network.cookie.prefsMigrated: true
network.predictor.cleaned-up: true
places.database.lastMaintenance: 1480969324
places.history.expiration.transient_current_max_pages: 104858
plugin.disable_full_page_plugin_for_types: application/pdf,video/msvideo,video/avi,video/x-msvideo,audio/x-wav,application/vnd.fdf,application/vnd.adobe.xdp+xml,ap
plugin.importedState: true
print.print_bgcolor: false
print.print_bgimages: false
print.print_colorspace:
print.print_command:
print.print_downloadfonts: false
print.print_duplex: 1515870810
print.print_evenpages: true
print.print_in_color: true
print.print_margin_bottom: 0.5
print.print_margin_left: 0.5
print.print_margin_right: 0.5
print.print_margin_top: 0.5
print.print_oddpages: true
print.print_orientation: 0
print.print_page_delay: 50
print.print_paper_data: 0
print.print_paper_height: 11.00
print.print_paper_name:
print.print_paper_size_type: 1
print.print_paper_size_unit: 0
print.print_paper_width: 8.50
print.print_plex_name:
print.print_resolution: 1515870810
print.print_resolution_name:
print.print_reversed: false
print.print_scaling: 1.00
print.print_shrink_to_fit: true
print.print_to_file: false
print.print_unwriteable_margin_bottom: 0
print.print_unwriteable_margin_left: 0
print.print_unwriteable_margin_right: 0
print.print_unwriteable_margin_top: 0
privacy.cpd.offlineApps: true
privacy.cpd.siteSettings: true
privacy.donottrackheader.enabled: true
privacy.sanitize.migrateClearSavedPwdsOnExit: true
privacy.sanitize.migrateFx3Prefs: true
privacy.sanitize.timeSpan: 0
security.disable_button.openCertManager: false
security.disable_button.openDeviceManager: false
security.ssl.errorReporting.automatic: true
services.sync.declinedEngines:
services.sync.engine.prefs.modified: false
services.sync.lastPing: 1480969022
services.sync.lastSync: Tue Dec 06 2016 11:41:34 GMT+0100 (CET)
services.sync.numClients: 2
storage.vacuum.last.index: 1
storage.vacuum.last.places.sqlite: 1480606278

Important Locked Preferences
----------------------------

Places Database
---------------

JavaScript
----------

Incremental GC: true

Accessibility
-------------

Activated: false
Prevent Accessibility: 0

Library Versions
----------------

NSPR
Expected minimum version: 4.12
Version in use: 4.12

NSS
Expected minimum version: 3.26.2
Version in use: 3.26.2

NSSSMIME
Expected minimum version: 3.26.2
Version in use: 3.26.2

NSSSSL
Expected minimum version: 3.26.2
Version in use: 3.26.2

NSSUTIL
Expected minimum version: 3.26.2
Version in use: 3.26.2

Experimental Features
---------------------

Sandbox
-------
For sure one of those could create the issue. Also, I see a lot of preferences modified, some of them were probably done by some of your extensions. 
I've installed a dozen of them and clearly the browser is acting slow but haven't managed to reproduce the beachball or any freeze. Maybe because I don't have enough data stored on the test profile I used, or maybe it's one of those I couldn't find in Mozilla Add-ons website.

If you still want to use the current bugged profile. I would suggest to navigate to about:addons page and disable them one by one until you find out which one is causing the issue. Let me know if you find it. 
Or sync your bookmarks and history and transfer them on a new clean profile where you can install only the extensions you need.

However, since I cannot reproduce the exact behavior and since this seems to be related to a 3rd party software based on your comment, I will close this issue as worksforme. If you still consider this to be a browser issue, please reopen it and provide more information.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(chaver4u)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.