Closed Bug 1321562 Opened 4 years ago Closed 4 years ago

crash when trying to capture video via getUserMedia on Android (regression)

Categories

(Firefox :: Site Permissions, defect)

53 Branch
Unspecified
Android
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 53
Tracking Status
firefox50 --- unaffected
firefox51 --- unaffected
firefox52 --- unaffected
firefox53 --- fixed

People

(Reporter: jesup, Assigned: jchen)

References

Details

(Keywords: regression, Whiteboard: crash)

Crash Data

Attachments

(1 file)

Crashes with this signature:
java.lang.ArrayStoreException: java.lang.String[] cannot be stored in an array of type java.lang.String[] at org.mozilla.gecko.util.GeckoBundle.fromJSONObject(GeckoBundle.java) 

https://crash-stats.mozilla.com/report/index/18bed549-5db3-41b7-aa77-6b35b2161201

When you try to capture video on Android.  
1. Got to https://mozilla.github.io/webrtc-landing/gum_test.html
2. Click on Video or Video + Audio
Boom

Stack looks pretty useless

Worked in the 2016-11-29 build per achronop.  Fails in build downloaded this morning 2016-12-1
Jim looks like fallout from one of your changes
Assignee: nobody → nchen
Flags: needinfo?(nchen)
Depends on: 1319496
This patch should fix the crash in GeckoBundle.fromJSONObject due to wrong
values array type. Also, fix a bug where the first element of a converted array
is repeated. r=me for trivial patch.
Attachment #8816183 - Flags: review+
Pushed by nchen@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/083ffc01652a
Fix bugs in GeckoBundle.fromJSONObject; r=me
Status: NEW → ASSIGNED
Flags: needinfo?(nchen)
https://hg.mozilla.org/mozilla-central/rev/083ffc01652a
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 53
Crash Signature: [@ java.lang.ArrayStoreException: java.lang.String[] cannot be stored in an array of type java.lang.String[] at org.mozilla.gecko.util.GeckoBundle.fromJSONObject(GeckoBundle.java)]
Blocks: 1319496
No longer depends on: 1319496
Version: 35 Branch → 53 Branch
You need to log in before you can comment on or make changes to this bug.