SeaMonkey 2.4x Win32 refuses to install on Celeron XPsp3.

RESOLVED DUPLICATE of bug 1276324

Status

--
major
RESOLVED DUPLICATE of bug 1276324
2 years ago
2 years ago

People

(Reporter: gtoole, Unassigned)

Tracking

SeaMonkey 2.46 Branch
x86
Windows

SeaMonkey Tracking Flags

(seamonkey2.46 wontfix, seamonkey2.47 affected, seamonkey2.48 affected, seamonkey2.49esr affected, seamonkey2.50 affected)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:50.0) Gecko/20100101 Firefox/50.0 SeaMonkey/2.47
Build ID: 20161121225139

Steps to reproduce:

Downloaded latest Win32 en-US builds of SeaMonkey 2.46 & 2.47 (seamonkey-2.46.en-US.win32.installer.exe, seamonkey-2.47.en-US.win32.installer.exe) on 2016/11/28 at 10:30 EST and installed 2.47 successfully on Win XPsp3 notebook (2.60 GHz Core2 Duo).  Then tried to install 2.47 on Win XPsp3 desktop (950 MHz Celeron).  Both machines have Windows version 2002.


Actual results:

After unpacking on the Celeron, installer stopped with Setup error message "Sorry, 'SeaMonkey' can't be installed. This version of 'SeaMonkey' requires Microsoft Windows XP SP2 or newer."  Only action allowed was to press "OK" button.
Then tried to install 2.46;  same result.
Then tried to install 2.38 (official release downloaded 2015/11/23);  successfully installed.


Expected results:

2.47 (or 2.46) should have installed successfully or, if there really is a reason for not installing, it should have displayed a message indicating the real problem (instead of incorrectly reporting that the OS is not XPsp3).
(Reporter)

Updated

2 years ago
Severity: normal → major
Keywords: reproducible
OS: Unspecified → Windows XP
Hardware: Unspecified → x86
Seamonkey 2.46 and 2.47 requires an SSE2 capable processor so its ok that it won't install. I am not sure there is an installer bug already open stating this eg. the corresponding Firefox bug has not been ported yet.
Status: UNCONFIRMED → NEW
status-seamonkey2.46: --- → wontfix
status-seamonkey2.47: --- → affected
status-seamonkey2.48: --- → affected
status-seamonkey2.49esr: --- → affected
status-seamonkey2.50: --- → affected
Ever confirmed: true
Keywords: reproducible
OS: Windows XP → Windows
Version: SeaMonkey 2.47 Branch → SeaMonkey 2.46 Branch
Actually the bug already exists.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1276324
(Reporter)

Comment 3

2 years ago
Understood, F-R G.  Looks like porting the fix for Firefox bug 1271759 to SeaMonkey will provide a more helpful error message.  Will the system requirements for SeaMonkey 2.4x also be updated to require SSE2?
GT

Comment 4

2 years ago
(In reply to gtoole from comment #0)

> Downloaded latest Win32 en-US builds of SeaMonkey 2.46 & 2.47
> (seamonkey-2.46.en-US.win32.installer.exe,
> seamonkey-2.47.en-US.win32.installer.exe) on 2016/11/28 at 10:30 EST and
> installed 2.47 successfully on Win XPsp3 notebook (2.60 GHz Core2 Duo). 
> Then tried to install 2.47 on Win XPsp3 desktop (950 MHz Celeron).  Both
> machines have Windows version 2002.
> 

The 950 Mhz Intel Celeron CPU you have is part of the "Coppermine" series, which is based on the Pentium 3 CPUs that do not have SSE2 support, gtoole.

SSE2 instructions were not implemented until the "Willamette" and "Northwood" series of Celeron CPUs came out, which were based on Pentium 4 CPUs.
https://en.wikipedia.org/wiki/Celeron

At least I can afford to replace an old motherboard & old CPU with boards that can support minimum Pentium 4 and/or Celeron CPUs that DO have SSE2 support; I had an Intel Celeron D 325J (2533 MHz) CPU that was based on the "Prescott" series that can handle the newest versions of Seamonkey well.

>Understood, F-R G.  Looks like porting the fix for Firefox bug 1271759 to SeaMonkey will provide a >more helpful error message.  Will the system requirements for SeaMonkey 2.4x also be updated to >require SSE2?
>GT

I think they should update the system requirements page for Seamonkey to mention CPUs with SSE2 like Mozilla did with Firefox:
https://www.mozilla.org/en-US/firefox/system-requirements/
You need to log in before you can comment on or make changes to this bug.