Closed Bug 132161 Opened 18 years ago Closed 12 years ago

Occurences of uninitialized variables being used before being set (in mailnews/imap)

Categories

(MailNews Core :: Networking: IMAP, defect)

x86
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 59673

People

(Reporter: mozilla-bugs, Assigned: mscott)

References

Details

This bug is just for the warning in nsImapProtocol.cpp:

mailnews/imap/src/nsImapProtocol.cpp:5521
 `PRInt32 longestIndex' might be used uninitialized in this function
Bug 59652 is the meta-bug tracking the fight against the "xxx might be used
uninitialized" warnings; bug 59673 is for such warnings in mailnews.
Blocks: 59652, 59673
is this bug valuable?
> is this bug valuable.

Well, the "might be used ininitialized" warnings often point to tricky and hard
to catch bugs (since things can behave semi-randomly depending on what the
contents of the uninitialized location happen to be). Because of that, it is
worth trying to minimize the number of such warnings that we have, fixing
(whenever reasonable) even the "compiler just not smart enough" ones...

For this particular one - I haven't yet checked whether it's a real problem or
just a compiler being stupid.
Summary: Occurances of uninitialized variables being used before being set (in mailnews/imap) → Occurences of uninitialized variables being used before being set (in mailnews/imap)
QA Contact: huang → gchan
Product: MailNews → Core
This issue was fixed by a patch in bug 59673 -> DUPE
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 59673
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.