Closed Bug 1321696 Opened 3 years ago Closed 3 years ago

Require Rust 1.13

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(firefox53 fixed)

RESOLVED FIXED
mozilla53
Tracking Status
firefox53 --- fixed

People

(Reporter: rillian, Assigned: rillian)

References

Details

Attachments

(1 file)

Bug 1320425 landed code which uses the '?' operator, stabilized in Rust 1.13.0. We should update the configure check to ensure this, rather than failing late in the build.
Nathan, you've argued we should hold off bumping the minimum
for another three weeks until 1.14 is stable: we plan to bump
the minimum then too, because we need cargo's Workspace feature,
and doing so twice in the same month is a burden on developers.

I don't find this pursuasive. Anyone who installed rust in
response to my dev-platform post last week about `./mach boostrap`
and will have 1.13. Anyone who installs it when the build
starts requiring rust will have 1.13 or 1.14 depending on when
bug 1283898 lands. The only devs who will see the double bump
are those who've already experimented with rust in the past
either with an --enable-rust in mozconfig or in projects outside
gecko. Either way they will have previous experience installing
rust, and it's reasonable to consider early adoption as opting-in
to a little more effort.

It's a better argument for not having sent my announcement last
week, but I wasn't aware at the time you were planning to bump
only when 1.14 came out. :/
Assignee: nobody → giles
Blocks: 1320425
In the future, things that require new compiler features should land *after* a requirement bump.
(In reply to Ralph Giles (:rillian) needinfo me from comment #2)
> Nathan, you've argued we should hold off bumping the minimum
> for another three weeks until 1.14 is stable: we plan to bump
> the minimum then too, because we need cargo's Workspace feature,
> and doing so twice in the same month is a burden on developers.

cargo workspaces are supported in cargo 0.13, which shipped with Rust 1.12, IIRC.
Ah, I must have misunderstood the IRC discussion. Is there a reason to bump the minimum to 1.14 then?
(In reply to Mike Hommey [:glandium] from comment #3)
> In the future, things that require new compiler features should land *after*
> a requirement bump.

I think the only way to ensure this is with automation. I opened bug 1321847 about that.
(In reply to Ralph Giles (:rillian) needinfo me from comment #5)
> Ah, I must have misunderstood the IRC discussion. Is there a reason to bump
> the minimum to 1.14 then?

Bumping the minimum to 1.14 would ensure that people who tried to compile Fennec would have a working compiler.  I don't know of other compelling reasons (wanted: in-progress release notes for the Beta Rust channel).
(In reply to Nathan Froyd [:froydnj] from comment #7)

> Bumping the minimum to 1.14 would ensure that people who tried to compile
> Fennec would have a working compiler.

Ah, right. I should write all this stuff down in one place somewhere.
Comment on attachment 8816338 [details]
Bug 1321696 - Require rust 1.13 with --enable-rust.

https://reviewboard.mozilla.org/r/97106/#review97578

As far as I can tell the argument from comment 3 is fine and still applies if the reason we want 1.14 when it comes out is for Android, not workspaces.
Attachment #8816338 - Flags: review?(cmanchester) → review+
(In reply to Chris Manchester (:chmanchester) from comment #9)
> Comment on attachment 8816338 [details]
> Bug 1321696 - Require rust 1.13 with --enable-rust.
> 
> https://reviewboard.mozilla.org/r/97106/#review97578
> 
> As far as I can tell the argument from comment 3 is fine and still applies
> if the reason we want 1.14 when it comes out is for Android, not workspaces.

Actually that's comment 2.
Pushed by rgiles@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/02aa6ad54a6e
Require rust 1.13 with --enable-rust. r=chmanchester
https://hg.mozilla.org/mozilla-central/rev/02aa6ad54a6e
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
Duplicate of this bug: 1314709
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.