If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

start_url property in manifest.json is not honored

RESOLVED DUPLICATE of bug 1234558

Status

()

Firefox for Android
General
RESOLVED DUPLICATE of bug 1234558
11 months ago
10 months ago

People

(Reporter: ddascalescu+github, Unassigned)

Tracking

50 Branch
Points:
---

Firefox Tracking Flags

(firefox50 affected, firefox51 affected, firefox52 affected, firefox53 affected)

Details

(URL)

(Reporter)

Description

11 months ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/54.0.2840.100 Safari/537.36
Firefox for Android

Steps to reproduce:

Adding to Home Screen a PWA at a certain URL appears to store that particular URL in the shortcut, and when tapping the icon, that URL is loaded in Firefox, instead of the start_url specified in manifest.json

1. Go to https://www.reservationcounter.com/hotels-pwa/show/152625/golden-nugget-hotel-and-casino/
2. From the overflow menu, choose Page -> Add to Home Screen
3. Close Firefox
4. Launch the PWA by tapping its icon from the home screen


Actual results:

The same URL as above loads


Expected results:

The / URL should have loaded (yes, that's a bug in the site's manifest.json, but Firefox should honor the property, as Chrome does).

Related: #1087469

Comment 1

11 months ago
I was able to reproduce the issue on all Firefox versions, using the steps to reproduce provided in the Description.


Device: Nexus 5 (Android 6.0.1);
Builds: 
- latest Nightly 53.0a1 (2016-12-05);
- latest Aurora 52.0a2 (2016-12-05);
- Beta 51.0b5;
- Release 50.0.2.
Status: UNCONFIRMED → NEW
status-firefox50: --- → affected
status-firefox51: --- → affected
status-firefox52: --- → affected
status-firefox53: --- → affected
Ever confirmed: true
See Also: → bug 1087469
This is going to be fixed as part of bug 1234558.
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1234558
You need to log in before you can comment on or make changes to this bug.