0.9.9-0 rpms conflict with standard Redhat 7.2

RESOLVED INVALID

Status

SeaMonkey
Build Config
RESOLVED INVALID
16 years ago
13 years ago

People

(Reporter: Zenon Panoussis, Assigned: blizzard)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.8) Gecko/20020204
BuildID:    20020319 (self-compiled)

Redhat 7.2 comes with Mozilla 0.9.2.1-2 . This:
# wget http://(mozilla)/mozilla0.9.9/Red_Hat_7x_RPMS/SRPMS/mozilla-0.9.9-0.src.rpm
# rpm -hiv mozilla-0.9.9-0.src.rpm
# rpm -ba /usr/src/redhat/SPECS/mozilla-0.9.9.spec
# rpm -Uhv /usr/rsc/redhat/RPMS/i386/mozilla*.rpm
results in a huge pile of conflicts. 


Reproducible: Always
Steps to Reproduce: Follow the procedure in "description".

Actual Results:  Long list of errors in the style of 
file /usr/lib/mozilla/components/libpipnss.so from install of
mozilla-psm-0.9.9-0 conflicts with file from package mozilla-psm-0.9.2.1-2
at steps 4 and 6 below.

Expected Results:  exit 0

This workaround worked:
1# wget http://(mozilla)/mozilla0.9.9/Red_Hat_7x_RPMS/SRPMS/mozilla-0.9.9-0.src.rpm
2# rpm -hiv mozilla-0.9.9-0.src.rpm
3# rpm -ba /usr/src/redhat/SPECS/mozilla-0.9.9.spec
4# rpm -Uhv /usr/rsc/redhat/RPMS/i386/mozilla*.rpm
5# rpm -e --nodeps mozilla
6# rpm -hiv /usr/rsc/redhat/RPMS/i386/mozilla*.rpm
7# rpm -hiv --force /usr/rsc/redhat/RPMS/i386/mozilla*.rpm
(galeon among others requires --nodeps and rpm itself forces --force).

The system is a Redhat 7.2 standard workstation with all the updates until
17-03-2002. 

Something needs to be fixed in the .spec file, it methinks.
-> redhat.com
Assignee: seawood → blizzard
(Reporter)

Comment 2

16 years ago
Forgot: between steps 5 and 6 in the workaround, 
# rm -rf /usr/lib/mozilla

rpm -Uhv and rpm -hiv kept reporting conflicts even after the mozilla 
directory had been removed, hence --force .

The installation that resulted out of this works fine, so this whole 
issue has to do with rpm trimming and not with the functionality of 
Mozilla itself.
(Assignee)

Comment 3

16 years ago
If you're running these rpms, you have to know what you are doing.  Not really a
bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

16 years ago
> ------- Additional Comments From blizzard@mozilla.org  2002-03-20 10:29 -------
> If you're running these rpms, you have to know what you are doing.  Not really a
> bug.

Thank you, that's really very informative. 

You might be right or wrong, but I deal with enough arrogant 
idiots every day to not need any more of this attitude. If you 
see something wrong in what I did, the least you could do is 
say what that is, for my sake and that of others. If you can't 
be bothered to at least do that, then don't ask for bug reports 
from people that don't know what they're doing. 

In short: **** you too. 

Z
(Assignee)

Comment 5

16 years ago
I wasn't being arrogant.  If you are going to try to install these on Red Hat
7.2, you have to know that you're going to have to rebuild some other components
and you're going to have to know how to drive rpm to get the proper bits
upgraded.  I was also saying that this isn't a bug in Mozilla.

In short: chill out.

C
(Reporter)

Comment 6

16 years ago
OK, fine, you were not being arrogant. But you are still not informative at all.
For one, these bug reports are helpful even in "no bug" situations, so you could
make the effort to mention exactly which "other components" need be rebuilt and
how to "drive rpm to get the proper bits upgraded". Besides, if anything needs
to be rebuilt outside Mozilla, it should be in the dependencies list of the rpm,
shouldn't it? This might not be a bug in Mozilla, but it still looks like a bug
in the rpm to me and it is certainly a bug in the documentation. 
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 7

16 years ago
this is ridiculous. I'm outta here.
QA Contact: granrose → oracle
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 8

15 years ago
Heavens... why is this still open? INVALID.
Status: NEW → RESOLVED
Last Resolved: 16 years ago15 years ago
Resolution: --- → INVALID
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.