Closed Bug 1321933 Opened 4 years ago Closed 3 years ago

Removing last contentEditable element causes textarea caret missing

Categories

(Core :: DOM: Selection, defect)

49 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1443902

People

(Reporter: danny0838, Assigned: m_kato)

Details

(Keywords: testcase)

Attachments

(1 file)

Attached file bug-illustration.html
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20161019084923

Steps to reproduce:

1. Focus a textarea.
2. Trigger a script that removes the last contentEditable element in the document.


Actual results:

The caret of the textarea is missing.


Expected results:

The caret of the textarea should not be missing.
Component: Untriaged → Editor
Keywords: testcase
Product: Firefox → Core
Component: Editor → Selection
I believe that this is fixed by bug 1443902.
Assignee: nobody → m_kato
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1443902
You need to log in before you can comment on or make changes to this bug.