Status

Developer Documentation
Macros/Templates
P5
normal
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: mtwwstj9, Assigned: arai)

Tracking

Details

(URL)

(Reporter)

Description

a year ago
:: Developer Documentation Request

      Request Type: Correction
     Gecko Version: unspecified
 Technical Contact: 

:: Details

Hi,when I edit https://developer.mozilla.org/ja/Add-ons/WebExtensions/Walkthrough
I encounter TemplateExecutionError.
Troubleshooting says "TemplateExecutionError errors appear when
KumaScript encounters an error in the macro. These errors can only be
fixed by admin users and need to be reported as bugs."
and I will do so.
Thanks for develop.
(Assignee)

Comment 1

a year ago
Thank you for filing a bug :)
I've fixed the template but looks like it's taking time to reflect the change.

the issue is specific to preview mode, and you should be able to publish the page without any issue.
Status: UNCONFIRMED → NEW
Ever confirmed: true
:arai We have brought macro editions to github: https://github.com/mozilla/kumascript

You need to make a PR there now. (It is brand new!)

cc/ Ryan that can assist you in case of problems.
(Assignee)

Comment 4

a year ago
as told on IRC, ni?-ing jwhitlock for handling PR above.
Flags: needinfo?(jwhitlock)
Thank you for the change, that does indeed look like the fix to me.

We haven't nailed down this process, but I believe the change should be reviewed by a template editor. We can discuss this at our all-hands meeting in Hawaii next week, and use this as a test case.
PR was reviewed by fscholz, merged to kumascript master, and this fix is now deployed to staging and production. Preview now works for https://developer.mozilla.org/ja/Add-ons/WebExtensions/Walkthrough

Thanks arai for the fix!
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(jwhitlock)
Resolution: --- → FIXED
(Assignee)

Updated

a year ago
See Also: → bug 1325352
(Assignee)

Comment 7

a year ago
taking, to make this search-able ;)
Assignee: nobody → arai.unmht
You need to log in before you can comment on or make changes to this bug.