Truncate very long strings in the Rules view

RESOLVED DUPLICATE of bug 1171857

Status

()

Firefox
Developer Tools: CSS Rules Inspector
RESOLVED DUPLICATE of bug 1171857
a year ago
11 months ago

People

(Reporter: Florens Verschelde, Unassigned)

Tracking

52 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Created attachment 8816675 [details]
current-result.png

Steps to reproduce:
1. Visit https://zachleat.github.io/browser-logo-icon-set/usage.html
2. Inspect one of the icons. (It’s a <b> element with a SVG data-uril as background-image.)

Current result:
The url(…) CSS values are really long, taking several kilobytes (around 1000-5000 ascii characters in this case). They take up several "screens" of the Rules view that you have to scroll through to get at other styles.

Possible improvement:
Truncate very long strings (maybe after 500 characters?) in the displayed value, only showing the full value in edit mode.

Updated

a year ago
Status: UNCONFIRMED → NEW
Component: Developer Tools: Inspector → Developer Tools: CSS Rules Inspector
Ever confirmed: true

Comment 1

11 months ago
Hi Florens,

Thanks for filing this bug. Just marking this as a duplicate of Bug 1171857.

Thanks,
Gabriel
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1171857
You need to log in before you can comment on or make changes to this bug.