Intermittent netwerk/test/unit/test_bug248970_cache.js | Test timed out After: Unable to verify Android boot completion

RESOLVED DUPLICATE of bug 1335501

Status

Testing
XPCShell Harness
RESOLVED DUPLICATE of bug 1335501
2 years ago
2 years ago

People

(Reporter: aryx, Assigned: gbrown)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

https://treeherder.mozilla.org/logviewer.html#?job_id=40277015&repo=mozilla-inbound

08:27:41     INFO -  TEST-START | netwerk/test/unit/test_bug248970_cache.js
08:32:41  WARNING -  TEST-UNEXPECTED-TIMEOUT | netwerk/test/unit/test_bug248970_cache.js | Test timed out
08:32:41     INFO -  TEST-INFO took 300054ms
08:32:51     INFO -  mozdevice Timeout exceeded for shell call 'adb shell /data/local/xpcb/xpcw /storage/sdcard/tests/xpc/netwerk/test/unit -r /storage/sdcard/tests/xpc/c/httpd.manifest --greomni /data/local/xpcb/fennec-53.0a1.en-US.android-arm.apk -m -s -e 'const _HEAD_JS_PATH = "/storage/sdcard/tests/xpc/head.js";' -e 'const _MOZINFO_JS_PATH = "/storage/sdcard/tests/xpc/p/mozinfo.json";' -e 'const _TESTING_MODULES_DIR = "/storage/sdcard/tests/xpc/m";' -f /storage/sdcard/tests/xpc/head.js -e 'const _SERVER_ADDR = "localhost"' -e 'const _HEAD_FILES = ["/storage/sdcard/tests/xpc/netwerk/test/unit/head_channels.js", "/storage/sdcard/tests/xpc/netwerk/test/unit/head_cache.js", "/storage/sdcard/tests/xpc/netwerk/test/unit/head_cache2.js"];' -e 'const _TAIL_FILES = [];' -e 'const _JSDEBUGGER_PORT = 0;' -e 'const _TEST_FILE = ["test_bug248970_cache.js"];' -e 'const _TEST_NAME = "netwerk/test/unit/test_bug248970_cache.js"' -e '_execute_test(); quit(0);'; echo $?'
08:33:11     INFO -  mozdevice Timeout exceeded for _runCmd call 'adb shell ps'
08:33:11     INFO -  xpcshell return code: 1480782467024
08:33:21     INFO -  mozdevice Timeout exceeded for _runCmd call 'adb shell ps'
08:33:51     INFO -  mozdevice Timeout exceeded for _runCmd call 'adb shell ps'
08:33:51  WARNING -  TEST-UNEXPECTED-FAIL | Received SIGINT (control-C), so stopped run. (Use --keep-going to keep running tests after killing one with SIGINT)

...

08:33:52     INFO - ##### test-1 emulator log ends
08:33:52  WARNING - # TBPL WARNING #
08:33:52  WARNING - setting return code to 1
08:33:52     INFO - Running post-action listener: _resource_record_post_action
08:33:52     INFO - Running post-action listener: stop_emulator
08:33:52     INFO - Verifying adb connectivity
08:33:52     INFO - Running timeout 180 /builds/slave/test/build/android-sdk18/platform-tools/adb wait-for-device
08:33:52     INFO - >> Verify emulator visible to adb: Attempt #1 of 4
08:33:52     INFO - Running timeout 30 /builds/slave/test/build/android-sdk18/platform-tools/adb devices
08:33:52     INFO - List of devices attached 
08:33:52     INFO - emulator-5554	device
08:33:52     INFO - >> Verify Android boot completed: Attempt #1 of 30
08:33:52     INFO - Running timeout 30 /builds/slave/test/build/android-sdk18/platform-tools/adb -s emulator-5554 shell getprop sys.boot_completed
08:34:22     INFO - Sleeping 10 seconds
08:34:32     INFO - >> Verify Android boot completed: Attempt #2 of 30
08:34:32     INFO - Running timeout 30 /builds/slave/test/build/android-sdk18/platform-tools/adb -s emulator-5554 shell getprop sys.boot_completed
08:35:02     INFO - Sleeping 10 seconds
08:35:12     INFO - >> Verify Android boot completed: Attempt #3 of 30
08:35:12     INFO - Running timeout 30 /builds/slave/test/build/android-sdk18/platform-tools/adb -s emulator-5554 shell getprop sys.boot_completed
08:35:42     INFO - Sleeping 10 seconds
08:35:52     INFO - >> Verify Android boot completed: Attempt #4 of 30
08:35:52     INFO - Running timeout 30 /builds/slave/test/build/android-sdk18/platform-tools/adb -s emulator-5554 shell getprop sys.boot_completed
08:36:22     INFO - Sleeping 10 seconds
08:36:32     INFO - >> Verify Android boot completed: Attempt #5 of 30
08:36:32     INFO - Running timeout 30 /builds/slave/test/build/android-sdk18/platform-tools/adb -s emulator-5554 shell getprop sys.boot_completed
08:37:02     INFO - Sleeping 10 seconds
08:37:12     INFO - >> Verify Android boot completed: Attempt #6 of 30
08:37:12     INFO - Running timeout 30 /builds/slave/test/build/android-sdk18/platform-tools/adb -s emulator-5554 shell getprop sys.boot_completed
08:37:42     INFO - Sleeping 10 seconds
08:37:52     INFO - >> Verify Android boot completed: Attempt #7 of 30
08:37:52     INFO - Running timeout 30 /builds/slave/test/build/android-sdk18/platform-tools/adb -s emulator-5554 shell getprop sys.boot_completed
08:38:22     INFO - Sleeping 10 seconds
08:38:32     INFO - >> Verify Android boot completed: Attempt #8 of 30
08:38:32     INFO - Running timeout 30 /builds/slave/test/build/android-sdk18/platform-tools/adb -s emulator-5554 shell getprop sys.boot_completed
08:39:02     INFO - Sleeping 10 seconds
08:39:12     INFO - >> Verify Android boot completed: Attempt #9 of 30
08:39:12     INFO - Running timeout 30 /builds/slave/test/build/android-sdk18/platform-tools/adb -s emulator-5554 shell getprop sys.boot_completed
08:39:43     INFO - Maximum retry run-time of 330 seconds exceeded; remaining attempts abandoned
08:39:43  WARNING - Unable to verify Android boot completion
08:39:43     INFO - Let's kill every process called emulator64-arm
08:39:43     INFO - Killing pid 1707.
Looks like something went wrong with the device (even 'adb shell ps' starts timing out) and it just happened to be during a network test.
Component: Networking: Cache → XPCShell Harness
Product: Core → Testing
Assignee: nobody → gbrown
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1335501
You need to log in before you can comment on or make changes to this bug.