bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Incorrect logo layout on web page (logos overlap)

RESOLVED DUPLICATE of bug 851048

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 851048
2 years ago
2 years ago

People

(Reporter: Mark Straver, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

2 years ago
On https://www.khronos.org/members/list the logos of the members in Firefox (tested nightly and release) overlap each other, and seem to render relatively slowly as well.

Chromium-derived browsers and MSIE render this properly-spaced.
The page loads the images lazily. It does this by submitting the html with the <img>s which don't contain a src attribute. According to bug 851048 comment 6, ignoring the width and height follows the spec. So if the behaviour should change, the spec should change.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 851048
(Reporter)

Comment 2

2 years ago
Right! So are the Google and Microsoft teams aware of this already?
bz, any chance the spec will get updated to reflect reality?
Flags: needinfo?(bzbarsky)
What reality, exactly?  Figuring out what you want the spec to say is the first step to figuring out whether it can be updated to say it.

Changing the spec to specifically make images without @src behave like images with an invalid src is probably doable.  But note that some other browsers don't follow the spec for images in various other cases too, and those cases can only be changed to align with those browsers if we give up on useful alt text altogether.

Not sure whether that all answers your question.
Flags: needinfo?(bzbarsky)
(Reporter)

Comment 5

2 years ago
I can understand if "all browsers do it a certain way" that that can be considered a spec issue. But here, the spec is clear and explicit and at least describing Mozilla's behavior (and possibly others'). I don't see a reason to consider "what chrome does" == "reality".

Just wondering if the other browsers are aware of their non-compliance or not. Why else do we have these specs?
> Just wondering if the other browsers are aware of their non-compliance or not.

I was pretty sure they were, but I filed https://bugs.chromium.org/p/chromium/issues/detail?id=671871 just now to make sure the Chrome folks are available.  Filing a bug on IE is a bit of a more involved process.
You need to log in before you can comment on or make changes to this bug.