ICal files do not open when downloaded

RESOLVED DUPLICATE of bug 1229088

Status

()

Firefox for Android
Download Manager
RESOLVED DUPLICATE of bug 1229088
a year ago
a year ago

People

(Reporter: topdroidmasterbugreport, Unassigned)

Tracking

49 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20161129173726

Steps to reproduce:

Using the mobile browser I downloaded a .ics file or ICal file through the download manager.


Actual results:

When Firefox tried to open the file it crashed.


Expected results:

It should have displayed a dialog to select an application that would be able to open the ICal file.
(Reporter)

Updated

a year ago
Crash Signature: [@mozilla::widget::GeckoAppShell::OpenUriExternal]
(Reporter)

Comment 2

a year ago
Sorry wrong one. This is my first bug report.
Actual report:
https://crash-stats.mozilla.com/report/index/b2e869a0-29c1-4985-8a5e-444dd2161203
(Reporter)

Updated

a year ago
Summary: ICal files do not open when downloaded → ICal files do not open when downloaded https://crash-stats.mozilla.com/report/index/b2e869a0-29c1-4985-8a5e-444dd2161203
Hello and thank you for the report.

I tried to reproduce the issue, but I didn't get any crash.
Instead, when I tapped on the downloaded .ics file a snackbar was displayed stating the following message: "Unable to launch event".

Tested with Nexus 5 (Android 6.0.1) and Nexus 9 (Android 7.0) on Firefox Release 49.0.2

Can you please upgrade your Firefox to the latest version and try to reproduce the crash?
Also, can you try to reproduce the issue on a Nightly build? https://www.mozilla.org/en-US/firefox/channel/android/

Thank you.
Flags: needinfo?(topdroidmasterbugreport)
(Reporter)

Comment 4

a year ago
I downloaded the nightly build onto my android 5.1 device, and it still crashed when I downloaded it. When I first clicked on the link it asked me whether to download or to open with calendar. I clicked download and it appeared in my notification bar as finished. And it then crashed the browser. After I submitted the crash report I found another bug back from late 2015 that described this problem.
Here's the new crash report:
https://crash-stats.mozilla.com/report/index/6fcf633e-0593-4e28-b421-94ce52161207
The file I used:
https://www.mozilla.org/media/caldata/AlgeriaHolidays.ics
Flags: needinfo?(topdroidmasterbugreport)
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Summary: ICal files do not open when downloaded https://crash-stats.mozilla.com/report/index/b2e869a0-29c1-4985-8a5e-444dd2161203 → ICal files do not open when downloaded
Duplicate of bug: 1229088
You need to log in before you can comment on or make changes to this bug.