No absolute CSS Selector path in Dev Tools!

RESOLVED DUPLICATE of bug 1323700

Status

DevTools
Inspector
RESOLVED DUPLICATE of bug 1323700
2 years ago
10 days ago

People

(Reporter: Joschka, Unassigned)

Tracking

50 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20161123182536

Steps to reproduce:

When I want to copy a CSS Selector path in the Dev Tools I get only the relative path.





Actual results:

When I copy the path in the Dev Tools I only get this:

.pull-right > img:nth-child(1)

That's nice... but there should be a second option to copy the absolute path like in Firebug! In the Dev Tools there is also no way to copy the Selector path in the breadcrumbs section like in Firebug! Some of you might say: Why do you need the whole path? I can tell ya...we need this to stlye e.g. only one special element on a special page or a special view!


Expected results:

When I copy the path in Firebug I get this:

html body.su-shortcodes-loaded div#background-grad div#background-img div#wrapper div#container div#contents div#compo div.blog-featured div.items-leading.clearfix div.leading-0.clearfix div.pull-right.item-image img

This is much more flexible for CSS developers coz here I can decide e.g. on which view I want to style the image like e.g.:

.blog-featured div.items-leading.clearfix div.leading-0.clearfix div.pull-right.item-image img
(Reporter)

Updated

2 years ago
Component: Untriaged → Developer Tools
(Reporter)

Updated

2 years ago
OS: Unspecified → All
Hardware: Unspecified → All

Updated

2 years ago
Component: Developer Tools → Developer Tools: Inspector
Hi Joschka,

Thanks for filing this. We have a duplicate bug for this feature in Bug 1323700 and will be looking to implementing this real soon.

Thanks,
Gabriel
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1323700

Updated

10 days ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.