The search icon overlaps the forward button when the back button is tapped

RESOLVED DUPLICATE of bug 1324280

Status

()

Firefox for Android
Awesomescreen
RESOLVED DUPLICATE of bug 1324280
7 months ago
4 months ago

People

(Reporter: sorina, Unassigned)

Tracking

(Blocks: 1 bug, {regressionwindow-wanted})

53 Branch
ARM
Android
regressionwindow-wanted
Points:
---

Firefox Tracking Flags

(firefox50 unaffected, firefox51 unaffected, firefox52 unaffected, firefox53+ fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 months ago
Created attachment 8816903 [details]
Screenshot_20161205-044804.jpg

Environment: 
Device: Asus ZenPad 8 (Android 6.0.1);
Build: Nightly 53.0a1 (2016-12-05);

Steps to reproduce:
1. Open Fennec;
2. Go to a page from Top Sites (e.g. Facebook);
3. Tap on back button to navigate to previous page (about:home);
4. Observe the URL toolbar.

Expected result:
The search icon is not overlapping the forward/back buttons.

Actual result:
The search icon overlaps the forward button.

Notes:
Please check the screenshot.
I couldn't reproduce on Nexus 9 (Android 7.0).

Comment 1

6 months ago
[Tracking Requested - why for this release]: Bad UI on small tablets, is likely to be visible very often.

I wonder if this is related to Bug 1319302 
https://hg.mozilla.org/mozilla-central/rev/120c84ca5362

A lot of that code is being reverted in Bug 1323763, so we should probably wait and see if landing that fixes it.

(I can reproduce on a Nexus 7 - so this seems to affect small tablets?)
tracking-firefox53: --- → ?
Tracking 53+ for this visible UI regression.
tracking-firefox53: ? → +
Sebastian, can you help find someone to work on this? Thanks.
Flags: needinfo?(s.kaspari)
Andrzej, is this something you can help with? It's a recent regression, in 53, so it would be nice to never ship with this problem.
Flags: needinfo?(ahunt)
(Reporter)

Comment 5

4 months ago
Tested again with Asus Zenpad 8 (Android 6.0.1) and Huawei MediaPad M2 (Android 5.1.1) and the issue is not reproducible following the steps from description, on latest Nightly (2017-02-21).
This is only in 53? Can we get a regression range?

@max: Random guess: Could this be caused by some of the RTL changes?
Flags: needinfo?(s.kaspari) → needinfo?(max)
Keywords: regressionwindow-wanted
tracking-fennec: --- → ?

Comment 7

4 months ago
I guess the symptom duplicate with Bug 1324280 which have been resolved fix on 53. Sorina also verified not reproducible on latest Nightly.

Mark as verified?
Blocks: 702845
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Flags: needinfo?(max)
Resolution: --- → DUPLICATE
Duplicate of bug: 1324280
tracking-fennec: ? → ---
Fixed in 53 in the duplicate bug.
Flags: needinfo?(ahunt)
status-firefox53: affected → fixed
You need to log in before you can comment on or make changes to this bug.