firefox version 50.0.2 on macos 10.12.1 does not save text files as text but as html

RESOLVED DUPLICATE of bug 1320377

Status

()

Core
Widget: Cocoa
RESOLVED DUPLICATE of bug 1320377
a year ago
a year ago

People

(Reporter: dan hitt, Unassigned)

Tracking

50 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Created attachment 8816916 [details]
2016_12_05_a_no_text.png

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20161129173726

Steps to reproduce:

(1) visit google.com
(2) file > save page as (from the menu)
(3) choose format of 'Text Files' at bottom of page
(4) enter a name such as 'x.txt' to make it unmistakable that you want to save text
(5) click on save



Actual results:

You get a warning panel that it will not save in text format, and it is then impossible to change the name of the output file in such a way as to end in .txt instead of .html; furthermore, when saved, the file is html, with lots of mark up and very little text.

(Note that google.com is just an example site, it seems to work this way everywhere.  And the behavior is new, starting this morning, with the firefox update.)


Expected results:

Selecting 'Text Files' should have made the browser save in text format.

Updated

a year ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Component: Untriaged → Widget: Cocoa
Product: Firefox → Core
Resolution: --- → DUPLICATE
Duplicate of bug: 1320377
You need to log in before you can comment on or make changes to this bug.