Edit As New Message does not honor wrap / flow

RESOLVED INVALID

Status

Thunderbird
Untriaged
RESOLVED INVALID
a year ago
a year ago

People

(Reporter: seans, Unassigned)

Tracking

45 Branch

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Created attachment 8816927 [details]
Screenshot 2016-12-05 14.02.13.png

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/54.0.2840.99 Safari/537.36

Steps to reproduce:

1) Author a new message with multiple lines that are long enough so they begin to wrap and do not use any carriage returns / line-breaks except for new paragraphs

2) Sending the message works correctly with the text flowing and wrapping as expected for both the recipient and when viewed in the Thunderbird Sent folder

3) Select the same message in Sent and choose Edit As New Message

4) New message to be edited is displayed and text is no longer wrapping / flowing and appears to have line-breaks

5) Do not edit the message and simply send it again and even though it looks like it doesn't wrap / flow, the outbound message will wrap when received by the recipient

6) Attempts to Forward or Edit As New on the 2nd iteration of the original message then have actual hard line-breaks and page width enforced and text wrap and flow no longer works

Attached screenshot shows the message on the left with correct wrap and flow.  That same message is displayed on the right side of the screenshot after choosing Edit As New Message

Have tried toggling the value in Config Editor on mail.wrap_long_lines with no effect


Actual results:

Edit As New Message and, sometimes, Forward a sent message injects line-breaks and text does not wrap or flow


Expected results:

If original text is wrapping and flowing, editing the message as new or forwarding the message should always continue to honor the wrapping.

Comment 1

a year ago
> 1) Author a new message with multiple lines that are long enough so they
> begin to wrap and do not use any carriage returns / line-breaks except for
> new paragraphs
From the screen shot it looks like we're talking about a plaintext message here. When entering a plaintext message (or a HTML) message, the text is wrapped to the screen width.

> 2) Sending the message works correctly with the text flowing and wrapping as
> expected for both the recipient and when viewed in the Thunderbird Sent
> folder
Good.

> 3) Select the same message in Sent and choose Edit As New Message
> 
> 4) New message to be edited is displayed and text is no longer wrapping /
> flowing and appears to have line-breaks
When editing a plaintext message as new you're placed into the plaintext editor which traditionally wraps to 72ch long lines. That can be controlled with mailnews.wraplength.

> 5) Do not edit the message and simply send it again and even though it looks
> like it doesn't wrap / flow, the outbound message will wrap when received by
> the recipient
Well, the message did wrap, but to the 72ch width. The default sending format is to send "format flowed", so yes, it's wrapped again to the screen in the Sent folder and when received. You can switch of flowing with mailnews.send_plaintext_flowed, but I suggest not to do that.

> 6) Attempts to Forward or Edit As New on the 2nd iteration of the original
> message then have actual hard line-breaks and page width enforced and text
> wrap and flow no longer works
Forward and "Edit as new" do different things. Forward indeed places the original plaintext message as a hard-wrapped block into the new message. "Edit as new" should behave like on the first iteration in point 4). What makes you say that the second iteration is different from the first and that there are now "hard link-breaks"?

Compare the message source of the first iteration message and the second iteration message (View > Message Source). They should be the same. Select text to visualise trailing spaces at the end of each line which make the flowing effect together with the header Content-Type: text/plain; charset=windows-1252; format=flowed.

If still in doubt, attach the messages here for inspection.

I'm pretty sure it all works as designed, but there is much confusion about plaintext editing.
(Reporter)

Comment 2

a year ago
Maybe something else has changed and I'm getting dropped into the plaintext editor now when I never was before? What is the default behavior for thunderbird - should it always be composing in HTML or does it run back to plaintext editing if you didn't deliberately introduce some formatting to the message?

Comment 3

a year ago
Nothing has changed. If your default is HTML composition, you will always compose in HTML. However, if your e-mail doesn't contain any "rich text" elements, it will be "dumbed" down to plaintext upon *sending*.

You can switch this off (this is new!) here:
Tools > Options, Composition, General, "Send Options" button:
Send message as plain text if possible.

That's the default and has always been the default behaviour, but now (in TB 45.x) you can switch it off.

The only way you can get into plaintext editing is by editing such a "dumbed down" message as new, or any other plaintext message you might have received from a mailing list or Bugzilla for that matter.

I get caught by this occasionally. I edit a sent message as new, and when I want to do some formatting, I realise that I got into the plaintext editor and have to start all over again.

Can I close this bug? All works as designed. Unless there is really a difference between the first iteration and the second iteration as per your comment #0, see last four paragraphs of my answer in comment #1.
(Reporter)

Comment 4

a year ago
I've just turned off the option you suggested and restarted thunderbird and it seems to be acting as it did for me in the past on newly created messages.

Is there much risk in disabling that default behavior for other possible recipients? Or is the vast majority of email clients going to be OK if my Thunderbird always tries to send HTML emails?

Comment 5

a year ago
Well, there is a sophisticated configuration in the address book to configure which format a person should receive. These days pretty much everyone can receive HTML apart from sending to mailing lists.

Looks like you're not answering my question re. 1st/2nd iteration, so I'm done here.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.