Closed Bug 1322186 Opened 8 years ago Closed 3 months ago

Make RTCIceCandidate members readonly and add members parsed from candidate string.

Categories

(Core :: WebRTC: Signaling, defect, P2)

defect

Tracking

()

RESOLVED FIXED
126 Branch
Tracking Status
firefox53 --- wontfix
firefox126 --- fixed

People

(Reporter: jib, Assigned: jib)

References

(Blocks 1 open bug, Regressed 1 open bug)

Details

(Keywords: dev-doc-complete)

Attachments

(1 file, 1 obsolete file)

After bug 1263312 we currently have:

interface RTCIceCandidate {
  attribute DOMString       candidate;
  attribute DOMString?      sdpMid;
  attribute unsigned short? sdpMLineIndex;

  jsonifier;
};

and the spec demands:

[Constructor(RTCIceCandidateInit candidateInitDict)]
interface RTCIceCandidate {
    readonly attribute DOMString               candidate;
    readonly attribute DOMString?              sdpMid;
    readonly attribute unsigned short?         sdpMLineIndex;
    readonly attribute DOMString               foundation;
    readonly attribute unsigned long           priority;
    readonly attribute DOMString               ip;
    readonly attribute RTCIceProtocol          protocol;
    readonly attribute unsigned short          port;
    readonly attribute RTCIceCandidateType     type;
    readonly attribute RTCIceTcpCandidateType? tcpType;
    readonly attribute DOMString?              relatedAddress;
    readonly attribute unsigned short?         relatedPort;
    serializer = {candidate, sdpMid, sdpMLineIndex};
};

The biggest problem here is probably the serializer, which only specifies that three of the attributes should be enumerated. I don't think our jsonifier syntax supports this, so this is probably blocking on bug 863402.
Rank: 25
Priority: -- → P2
The most recent editor draft version still contains this syntax is:

[Constructor(optional RTCIceCandidateInit candidateInitDict)]
interface RTCIceCandidate {
    readonly attribute DOMString               candidate;
    readonly attribute DOMString?              sdpMid;
    readonly attribute unsigned short?         sdpMLineIndex;
    readonly attribute DOMString?              foundation;
    readonly attribute RTCIceComponent?        component;
    readonly attribute unsigned long?          priority;
    readonly attribute DOMString?              ip;
    readonly attribute RTCIceProtocol?         protocol;
    readonly attribute unsigned short?         port;
    readonly attribute RTCIceCandidateType?    type;
    readonly attribute RTCIceTcpCandidateType? tcpType;
    readonly attribute DOMString?              relatedAddress;
    readonly attribute unsigned short?         relatedPort;
    readonly attribute DOMString?              ufrag;
    serializer = {candidate, sdpMid, sdpMLineIndex, ufrag};
};

But there is a issue open to replace serializer with toJSON https://github.com/w3c/webrtc-pc/issues/1419 for which this PR exists https://github.com/w3c/webrtc-pc/pull/1449
Mass change P2->P3 to align with new Mozilla triage process.
Priority: P2 → P3
There is no more jsonifier.  You can either do a toJSON with default behavior or write a custom one, however you prefer.
Severity: normal → S3
Priority: P3 → P2
Assignee: nobody → jib
Status: NEW → ASSIGNED

Comment on attachment 9390061 [details]
Bug 1322186 - fix mach lint warning in PeerConnection.sys.mjs. r?bwc

Revision D203976 was moved to bug 1882399. Setting attachment 9390061 [details] to obsolete.

Attachment #9390061 - Attachment is obsolete: true
Summary: Add remaining attributes to RTCIceCandidate → Add ICE-parsed attributes to RTCIceCandidate
Blocks: 1886013
Attachment #9390253 - Attachment description: Bug 1322186 - Make RTCIceCandidate members readonly and add remaining members. r?bwc → Bug 1322186 - Make RTCIceCandidate members readonly and add members parsed from candidate string. r?bwc
Summary: Add ICE-parsed attributes to RTCIceCandidate → Make RTCIceCandidate members readonly and add members parsed from candidate string.
Pushed by jbruaroey@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1957e76267e3
Make RTCIceCandidate members readonly and add members parsed from candidate string. r=bwc,webidl,smaug
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 126 Branch
Duplicate of this bug: 1812346
Duplicate of this bug: 1533019
Duplicate of this bug: 1527914

FF126 MDN docs work for this can be tracked in https://github.com/mdn/content/issues/33085. Essentially just a release note and browser compat data update.

Regressions: 1896866
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: