Video freezes when capturing stream from mediaDevices multiple times

RESOLVED WORKSFORME

Status

()

P3
normal
Rank:
25
RESOLVED WORKSFORME
2 years ago
7 months ago

People

(Reporter: leahcimic, Unassigned)

Tracking

({testcase})

53 Branch
testcase
Points:
---

Firefox Tracking Flags

(firefox52 wontfix, firefox53 affected)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/54.0.2840.98 Safari/537.36

Steps to reproduce:

I have created a jsfiddle that reproduces the problem:

https://jsfiddle.net/bdj700nu/

Once the video is playing, press Run to destroy that video and capture a new one. Do this a few times and you'll notice it stops working and the video is frozen.


Actual results:

The video refuses to play


Expected results:

The video should play

Updated

2 years ago
Component: Untriaged → WebRTC: Audio/Video
Keywords: testcase
Product: Firefox → Core

Comment 1

2 years ago
I can't reproduce it on Win 7.

Comment 2

2 years ago
Ah, it's FF53. I tested on FF50.
Thanks for the test! I can confirm this in Firefox 52. Symptoms are very similar to bug 1321853, but this seems like we're competing with ourselves rather than another process.
Status: UNCONFIRMED → NEW
Rank: 25
status-firefox52: --- → affected
status-firefox53: --- → affected
Ever confirmed: true
Priority: -- → P2
See Also: → bug 1321853
Could you try if requesting video only like https://jsfiddle.net/qwyemeq2/ ?
If the issue doesn't occur while requesting video only, then this bug should be duplicated to bug 1321714.
Flags: needinfo?(leahcimic)
Mass wontfix for bugs affecting firefox 52.
status-firefox52: affected → wontfix
Mass change P2->P3 to align with new Mozilla triage process.
Priority: P2 → P3
(Reporter)

Comment 7

7 months ago
I tested this in latest stable 60.0.2 (64-bit), and it is no longer an issue.
Flags: needinfo?(leahcimic)
(Reporter)

Updated

7 months ago
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.