Closed Bug 132220 Opened 18 years ago Closed 18 years ago

"search for" popup menu item opens new window instead of new tab

Categories

(SeaMonkey :: Search, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 133117
mozilla1.0.1

People

(Reporter: benb, Assigned: samir_bugzilla)

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:0.9.9) Gecko/20020311
BuildID:    2002031103

The "search for" item in the popup menu that uses the default search engine to
search for highlighted text now (in 0.9.9) opens search results in a new window
which is much less useful than the old behavior of opening them in a tab.
Mozilla appears to have no way to configure this back to the old behavior.


Reproducible: Always
Steps to Reproduce:
1.highlight some text in current page displayed in browser
2.right click to bring up ppoup menu, and select "search for ..."
3.

Actual Results:  search results popup in a new window

Expected Results:  search results appear in a tab in current window (0.9.6,7
behavior)
No dupe, confirming.

Could we include this in the "Middle-click or Ctrl-click of links in a Web page"
pref ? It's vaguely related.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Solaris → All
Hardware: Sun → All
We start opening results in new windows for bug 122162 but failed to honor the
``open in tab intead of window'' pref.
Target Milestone: --- → mozilla1.0.1
Summary: "search for" popup menu item opens new window → "search for" popup menu item opens new window instead of new tab
Although this bug is a few days older than bug 133117, the latter has 5 votes
and a lot of people in the CC

*** This bug has been marked as a duplicate of 133117 ***
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.