Crashing on displaying/downloading some mail with 'Assertion failure: !mDoingStableStates'

RESOLVED INVALID

Status

--
critical
RESOLVED INVALID
2 years ago
5 months ago

People

(Reporter: dexter, Unassigned)

Tracking

(Depends on: 1 bug, {crash, perf, testcase})

45 Branch
crash, perf, testcase

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2018-06-15])

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20161124113708

Steps to reproduce:

Showing or downloading mail. Sometimes it takes 20~30 tries starting thunderbird in the morning. 
When I click on some mail messages (with HTML) thunderbird crashes.
full version: thunderbird-45.5.1-1.fc25.x86_64



Actual results:

Thunderbird crashed, stacktrace:

Assertion failure: !mDoingStableStates, at /builddir/build/BUILD/thunderbird-45.5.1/thunderbird-45.5.1/mozilla/xpcom/base/CycleCollectedJSRuntime.cpp:1057
#01: ???[/usr/lib64/thunderbird/libxul.so +0x110e3b2]
#02: ???[/usr/lib64/thunderbird/libxul.so +0xcf4ddf]
#03: ???[/usr/lib64/thunderbird/libxul.so +0xd0ee4b]
#04: ???[/usr/lib64/thunderbird/libxul.so +0xcf6d34]
#05: ???[/usr/lib64/thunderbird/libxul.so +0xa58320]
#06: ???[/usr/lib64/thunderbird/libxul.so +0x1beb30d]
#07: ???[/usr/lib64/thunderbird/libxul.so +0x1beb4d8]
#08: ???[/usr/lib64/thunderbird/libxul.so +0x1beca39]
#09: ???[/usr/lib64/thunderbird/libxul.so +0x1be6755]
#10: ???[/usr/lib64/thunderbird/libxul.so +0x1c26890]
#11: ???[/usr/lib64/thunderbird/libxul.so +0x1c26983]
#12: ???[/usr/lib64/thunderbird/libxul.so +0x1c26a7b]
#13: ???[/usr/lib64/thunderbird/libxul.so +0x1c7d2fc]
#14: ???[/usr/lib64/thunderbird/libxul.so +0x1b7d55b]
#15: ???[/usr/lib64/thunderbird/libxul.so +0x1b0f563]
#16: ???[/usr/lib64/thunderbird/libxul.so +0x1b2ae2f]
#17: ???[/usr/lib64/thunderbird/libxul.so +0x1b2b935]
#18: ???[/usr/lib64/thunderbird/libxul.so +0x1b2b993]
#19: ???[/usr/lib64/thunderbird/libxul.so +0x1b047c2]
#20: ???[/usr/lib64/thunderbird/libxul.so +0x1b016ed]
#21: ???[/usr/lib64/thunderbird/libxul.so +0xcba8fb]
#22: ???[/usr/lib64/thunderbird/libxul.so +0x110e3b2]
#23: ???[/usr/lib64/thunderbird/libxul.so +0xcf4ddf]
#24: ???[/usr/lib64/thunderbird/libxul.so +0xd0ee4b]
#25: ???[/usr/lib64/thunderbird/libxul.so +0xef61bf]
#26: ???[/usr/lib64/thunderbird/libxul.so +0xee1278]
#27: ???[/usr/lib64/thunderbird/libxul.so +0x1efc2f4]
#28: ???[/usr/lib64/thunderbird/libxul.so +0x24d9b94]
#29: ???[/usr/lib64/thunderbird/libxul.so +0x250fcba]
#30: ???[/usr/lib64/thunderbird/libxul.so +0x250ff85]
#31: XRE_main[/usr/lib64/thunderbird/libxul.so +0x25101d4]
#32: ???[/usr/lib64/thunderbird/thunderbird +0x4fd2]
#33: ???[/usr/lib64/thunderbird/thunderbird +0x471a]
#34: __libc_start_main[/lib64/libc.so.6 +0x20401]
#35: _start[/usr/lib64/thunderbird/thunderbird +0x484a]
#36: ??? (???:???)



Expected results:

Not sure how to make a 'proper' gdb backtrace since there is no coredump.
Attached the eml file that caused the crash.
Of course tries to repair folder, safe mode, even deleted entire profile.

Comment 1

2 years ago
see https://developer.mozilla.org/en-US/docs/Mozilla/How_to_get_a_stacktrace_for_a_bug_report

> Attached the eml file that caused the crash.
you missed attaching the file :)
Severity: normal → critical
Flags: needinfo?(dexter)
Keywords: crash
(Reporter)

Comment 2

2 years ago
(In reply to Wayne Mery (:wsmwk, NI for questions) from comment #1)

> > Attached the eml file that caused the crash.
> you missed attaching the file :)

Of course, it is an unwritten rule to forget attachments in the mail. Goes as well for the bugzilla about the mail :)
Will fix, and will work on the backtrace.
(Reporter)

Comment 3

2 years ago
Created attachment 8817146 [details]
Mail making it crash
(Reporter)

Comment 4

2 years ago
Created attachment 8817154 [details]
Backtrace
Flags: needinfo?(dexter)

Comment 5

2 years ago
I don't crash but boy is there a performance hit. Perhaps in spinning through all the links in the email - ala bug 383718
and bug 115160
Keywords: perf, testcase

Updated

2 years ago
Component: Untriaged → Message Reader UI
Depends on: 383718

Comment 6

2 years ago
Arjen,
Can you make it crash with a mozilla build and get a crash ID? It would be a big help.
https://www.mozilla.org/en-US/thunderbird/
https://support.mozilla.org/en-US/kb/mozilla-crash-reporter#w_viewing-crash-reports
Flags: needinfo?(dexter)
(Reporter)

Comment 7

2 years ago
(I have not forgotten, I will comply to your request. Busy lately)

Comment 8

5 months ago
Arjen,
All better?
Whiteboard: [closeme 2018-06-15]
(Reporter)

Comment 9

5 months ago
All better.
Flags: needinfo?(dexter)
(Reporter)

Updated

5 months ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.