Remove browser.preferences.animateFadeIn and its code

VERIFIED FIXED in Firefox 53

Status

()

--
major
VERIFIED FIXED
2 years ago
a year ago

People

(Reporter: Virtual, Assigned: jordan, Mentored)

Tracking

(Blocks: 1 bug, {nightly-community})

unspecified
Firefox 53
nightly-community
Points:
---

Firefox Tracking Flags

(firefox53 verified)

Details

Attachments

(1 attachment)

Remove obsolete not working "browser.preferences.animateFadeIn" preference from about:config and its code,
especially when patches from bug #1140495 and bug #738797 landed very long time ago.
Has Regression Range: --- → irrelevant
Has STR: --- → irrelevant

Comment 1

2 years ago
Ready to take this , if someone is ready to mentor
(In reply to pass2pawan from comment #1)
> Ready to take this , if someone is ready to mentor

I can mentor this, please feel free to ask any questions that you may have.
Assignee: nobody → jaws
Assignee: jaws → nobody
Mentor: jaws
(Assignee)

Comment 3

2 years ago
Hi, I would like to fix this bug, please assign this to me. Thanks!
Comment hidden (mozreview-request)
(Assignee)

Comment 5

2 years ago
Also, I've attached a patch file, due to some reason I'm not able to test it. Please check this, and inform me for any changes.
Assignee: nobody → souravgarg833
Status: NEW → ASSIGNED
Hi Jorg, can you please test the attached patch with Thunderbird to make sure we're not breaking your preference implementation?
Flags: needinfo?(jorgk)

Comment 7

2 years ago
Thanks for the heads-up. This looks like a theme issue and I'm not a specialist there, but I know someone who is.

Richard, can you please take a look. If you're not so familiar with Review Board, you can download the patch here: https://reviewboard.mozilla.org/r/100208/diff/raw/

Updated

2 years ago
Flags: needinfo?(jorgk) → needinfo?(richard.marti)
For the record, SeaMonkey and Instantbird use also the window prefs. And the animation is only used on macOS.
Florian, from the perspective of Instantbird, would you be OK if this pref was removed?
Flags: needinfo?(florian)
I would like if this pref could stay.

And I tested the patch and the prefs are still working except one box which depends on #MailPreferences[animated="true|false"], but this would be easy to fix.
Flags: needinfo?(richard.marti)
Comment on attachment 8820774 [details]
Bug 1322251 - Remove browser.preferences.animateFadeIn and its code;

https://reviewboard.mozilla.org/r/100208/#review100794

Ok, thanks for the feedback. We can remove the pref from firefox.js and the /browser/themes files, but please leave /toolkit unchanged.
Attachment #8820774 - Flags: review?(jaws) → review-
Comment hidden (mozreview-request)
(Assignee)

Comment 13

2 years ago
Jared, I've removed all the changes from /toolkit. Please have a look.
(In reply to Jared Wein [:jaws] (please needinfo? me) from comment #9)
> Florian, from the perspective of Instantbird, would you be OK if this pref
> was removed?

Instantbird still uses this pref for OS X, yes.
Flags: needinfo?(florian)
Comment on attachment 8820774 [details]
Bug 1322251 - Remove browser.preferences.animateFadeIn and its code;

https://reviewboard.mozilla.org/r/100208/#review101068

Thanks! I'll get this pushed to autoland. It should make its way in to Firefox Nightly in the next two days :)
Attachment #8820774 - Flags: review?(jaws) → review+

Comment 16

2 years ago
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/041d65a057dc
Remove browser.preferences.animateFadeIn and its code; r=jaws

Comment 17

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/041d65a057dc
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox53: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 53

Comment 18

2 years ago
SeaMonkey is ok if this pref is removed.
Status: RESOLVED → VERIFIED
status-firefox53: fixed → verified
You need to log in before you can comment on or make changes to this bug.