Closed Bug 1322323 Opened 3 years ago Closed 3 years ago

Artifact builds on try: InvalidOptionError: --enable-rust (or RUSTC) is not available

Categories

(Testing :: General, defect)

defect
Not set

Tracking

(firefox53 fixed)

RESOLVED FIXED
mozilla53
Tracking Status
firefox53 --- fixed

People

(Reporter: maja_zf, Assigned: rillian)

References

Details

Attachments

(1 file)

Pretty sure this is fallout from bug 1321073.  Ralph, can you look at this?
Blocks: 1321073
Flags: needinfo?(giles)
Thanks for the report. I have to solve this for bug 1283898 anyway; I'll see what I can do.
Assignee: nobody → giles
Blocks: 1283898
Flags: needinfo?(giles)
The android-api-15/nightly-artifact mozconfig include mozconfig.rust, which until bug 1283898 lands passes `--enable-rust` to configure, but that option is disabled by the subsequent `--disable-compile-environment`. So this line is wrong and should be removed.

However, nightly-artifact also inherits from the android-api-15/nightly mozconfig, which _also_ includes mozconfig.rust. That like it correct. The problem is the `--enable-rust` line needs to be conditional on `enable-compile-environment` for this kind of inheritance to work.

How urgent is this bug? Enabling rust by default will let us drop `--enable-rust` from mozconfig.rust and we'll have the correct (default) behaviour either way. That's blocked on fixing other tier-2 task configs, but I hope to get that landed later next week. If you can wait, that's the easy fix. If this is blocking your work, we should back out bug 1321073.
Flags: needinfo?(mjzffr)
We can wait until later next week, thanks.
Flags: needinfo?(mjzffr)
Duplicate of this bug: 1322713
Ok, thanks. I'll come back to this after the default change has landed.
I see that Bug 1283898 has landed -- is that what you wanted to wait for?

We're now also seeing rust-related failures for artifact builds on Windows, as in https://treeherder.mozilla.org/#/jobs?repo=try&revision=9c49f50d536f16e694aa7d8ca9f5e9de2a52c7f7&selectedJob=33094498
Flags: needinfo?(giles)
Summary: Android artifact builds on try: InvalidOptionError: --enable-rust is not available → Artifact builds on try: InvalidOptionError: --enable-rust (or RUSTC) is not available
Duplicate of this bug: 1324732
Yes, I expected that bug to fix this one. More investigation is needed, clearly.
Flags: needinfo?(giles)
Ok, sorry. bug 1283898 fixed passing --enable-rust to artifact builds, but didn't fix the underlying problem of including mozconfig.rust. That file still defines RUSTC and CARGO conflict with --disable-compile-environment, implied by --enable-artifact-builds.

A clean-ish way to fix this is to add a mozconfig.artifact which unsets RUSTC, CARGO, CC, CXX and include that everywhere to override mozconfig.rust. It can also collect other common artifact settings like --enable-artifact-builds. The alternative is to go back to including mozconfig.rust in most of the the leaf mozconfigs, which I think still works out to more jobs.
Question: many, but not all, of the artifact mozconfigs pass --enable-artifact-build-symbols. Should I put that in the common mozconfig, or is it important that some jobs don't include that?
Flags: needinfo?(mjzffr)
I think only the Android artifact mozconfigs don't include --enable-artifact-build-symbols, and they should not.
Flags: needinfo?(mjzffr)
Ok, thanks!
Comment on attachment 8820940 [details]
Bug 1322323 - Consolidate common artifact build mozconfig options.

https://reviewboard.mozilla.org/r/100324/#review100856

Looks good to me. Thank you for the patch.
Attachment #8820940 - Flags: review?(cmanchester) → review+
Pushed by rgiles@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a9ba8e8f983a
Consolidate common artifact build mozconfig options. r=chmanchester
https://hg.mozilla.org/mozilla-central/rev/a9ba8e8f983a
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
You need to log in before you can comment on or make changes to this bug.