Add Windows 10 detection

RESOLVED FIXED in Firefox 51

Status

()

Toolkit
NSIS Installer
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: rstrong, Assigned: rstrong)

Tracking

unspecified
mozilla53
Points:
---

Firefox Tracking Flags

(firefox51 fixed, firefox52 fixed, firefox53 fixed)

Details

Attachments

(1 attachment)

We've added code to detect other OS's due to not being able to get the latest version of NSIS on the build systems (see bug 1236624) and we can do that for windows 10 as well. Patch coming up.
Created attachment 8817139 [details] [diff] [review]
patch
Attachment #8817139 - Flags: review?(mhowell)
Attachment #8817139 - Flags: review?(mhowell) → review+

Comment 2

a year ago
Pushed by rstrong@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/2a0223e35b0e
Add Windows 10 detection to the installer. r=mhowell

Comment 3

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/2a0223e35b0e
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
status-firefox53: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
Comment on attachment 8817139 [details] [diff] [review]
patch

Approval Request Comment

[Feature/Bug causing the regression]:
N/A

[User impact if declined]:
We're getting incorrect and misleading data from our stub installer metrics because Windows 10 is being incorrectly detected as 8.1. This isn't a new regression, but it was only recently detected because that data only recently became available to easily query.

[Is this code covered by automated tests?]:
No

[Has the fix been verified in Nightly?]:
Yes

[Needs manual test from QE? If yes, steps to reproduce]: 
No, it's been verified manually already.

[List of other uplifts needed for the feature/fix]:
None

[Is the change risky?]:
No

[Why is the change risky/not risky?]:
We've done almost exactly the same thing before for Windows 7, and the change only adds detection for the new version, it doesn't modify any existing ones.

[String changes made/needed]:
N/A
Attachment #8817139 - Flags: approval-mozilla-beta?
Attachment #8817139 - Flags: approval-mozilla-aurora?
Comment on attachment 8817139 [details] [diff] [review]
patch

detect windows 10 in the installer, take in aurora52
Attachment #8817139 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
status-firefox51: --- → affected
status-firefox52: --- → affected
Comment on attachment 8817139 [details] [diff] [review]
patch

Add detection for win 10. Beta51+. Should be in 51 beta 7.
Attachment #8817139 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Comment 7

a year ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-aurora/rev/6dc907d4ad6f
status-firefox52: affected → fixed

Comment 8

a year ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-beta/rev/563aed975b1f
status-firefox51: affected → fixed
You need to log in before you can comment on or make changes to this bug.