imap account / subscription info lost after crash and restart (gmail)

RESOLVED WORKSFORME

Status

Thunderbird
Untriaged
RESOLVED WORKSFORME
a year ago
5 days ago

People

(Reporter: Steve Kelem, Unassigned)

Tracking

(Blocks: 1 bug)

45 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dupme][notacrash])

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/53.0.2785.143 Chrome/53.0.2785.143 Safari/537.36

Steps to reproduce:

After thunderbird crashes (which is many times/day), I restart thunderbird.
Right click on Gmail account, select Subscribe, and the Subscription window folder list is empty. 


Actual results:

my Gmail imap account shows only Inbox. If I click on that Inbox, I get:
Unable to open the summary file for Inbox. Perhaps there was an error on disk, or the full path is too long.
My disk has 78G free. The paths are unchanged, and were working for many years before this last month.
Console shows:
(thunderbird:3311): Pango-WARNING **: failed to create cairo scaled font, expect ugly output. the offending font is 'DejaVu Serif 12'
(thunderbird:3311): Pango-WARNING **: font_face status is: <unknown error status>
(thunderbird:3311): Pango-WARNING **: scaled_font status is: out of memory
(thunderbird:3311): Pango-WARNING **: shaping failure, expect ugly output. shape-engine='PangoFcShapeEngine', font='DejaVu Serif 12', text='_File'
(thunderbird:3311): Gtk-WARNING **: Error loading theme icon 'gtk-cancel' for stock: Error opening file /usr/share/icons/Humanity/actions/16/gtk-cancel.svg: Too many open files
(thunderbird:3311): Gtk-WARNING **: Error loading theme icon 'gtk-ok' for stock: Error opening file /usr/share/icons/Humanity/actions/16/gtk-ok.svg: Too many open files
(thunderbird:3311): Gtk-WARNING **: Error loading theme icon 'dialog-warning' for stock: Error opening file /usr/share/icons/Humanity/status/48/dialog-warning.svg: Too many open files

Sometimes I get a popup to enter my Google credentials, sometimes I have to click on Subscribe to get that popup. I re-enter my Google account info, re-enter new Google Authenticator id.
Then it finds all my Gmail folders, and proceeds to re-download all my online messages in all my gmail folders.
When my Gmail folders are re-read, my Thunderbird filters process the messages...again...resulting in multiple copies of the same messages in the appropriate folders.


Expected results:

Thunderbird should remember my credentials, as it has done for many years. I should not have to re-enter this stuff several times/day. I should not have to re-subscribe to all my folders. I should not have to go through all my hundreds of mail folders and manually run "Remove Duplicates".
(In reply to Steve Kelem from comment #0)
> User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like
> Gecko) Ubuntu Chromium/53.0.2785.143 Chrome/53.0.2785.143 Safari/537.36
> 
> Steps to reproduce:
> 
> After thunderbird crashes (which is many times/day), I restart thunderbird.

Indeed, you do crash many times a day. You've also got Firefox too.  So there are issues going on. Have you tried safe mode or disabling half of your long list of addons?

So in the last couple days...
bp-ca3ca061-0659-4b18-9af4-402fa2161207 2016-12-07 20:40:50 js::UncheckedUnwrap    	Thunderbird
bp-ebfad197-43fc-4c2f-8be3-9c0832161207 2016-12-07 08:19:42 mozilla::FrameLayerBuilder::CheckDOMModified    	Firefox
bp-84c8c97c-71b3-4caf-aace-398a42161207 2016-12-07 03:46:22 libglib-2.0.so.0.5000.0@0x4a689    	Thunderbird
bp-71d1841d-0d34-4c7d-ab38-823d72161206 2016-12-06 23:09:27 js::jit::ICStub::trace    	Thunderbird
bp-0a75595e-486f-4cfa-af99-19eac2161206 2016-12-06 23:03:07 js::jit::ICStub::trace    	Firefox
bp-9ff4f0a4-9ac8-4116-be4e-dfa8a2161206 2016-12-06 21:11:27 mozilla::FrameLayerBuilder::CheckDOMModified    	Firefox
bp-d17ce042-4c52-4d12-922d-557b82161204 2016-12-04 04:52:17 js::detail::HashTable<T>::lookup | js::EmptyShape::getInitialShape    	Firefox 


> Right click on Gmail account, select Subscribe, and the Subscription window
> folder list is empty. 
>
> Actual results:
> 
> my Gmail imap account shows only Inbox. If I click on that Inbox, I get:
> Unable to open the summary file for Inbox. Perhaps there was an error on
> disk, or the full path is too long.

"Unable to open" is the point to focus on. This could also be due to corrupted summary file, or out of file handles - which is something you have reported experiencing in the past. And, which seems consistent with console items you list below

> My disk has 78G free. The paths are unchanged, and were working for many
> years before this last month.
> Console shows:
> (thunderbird:3311): Pango-WARNING **: failed to create cairo scaled font,
> expect ugly output. the offending font is 'DejaVu Serif 12'
> (thunderbird:3311): Pango-WARNING **: font_face status is: <unknown error
> status>
> (thunderbird:3311): Pango-WARNING **: scaled_font status is: out of memory
> (thunderbird:3311): Pango-WARNING **: shaping failure, expect ugly output.
> shape-engine='PangoFcShapeEngine', font='DejaVu Serif 12', text='_File'
> (thunderbird:3311): Gtk-WARNING **: Error loading theme icon 'gtk-cancel'
> for stock: Error opening file
> /usr/share/icons/Humanity/actions/16/gtk-cancel.svg: Too many open files
> (thunderbird:3311): Gtk-WARNING **: Error loading theme icon 'gtk-ok' for
> stock: Error opening file /usr/share/icons/Humanity/actions/16/gtk-ok.svg:
> Too many open files
> (thunderbird:3311): Gtk-WARNING **: Error loading theme icon
> 'dialog-warning' for stock: Error opening file
> /usr/share/icons/Humanity/status/48/dialog-warning.svg: Too many open files
> 
> Sometimes I get a popup to enter my Google credentials, sometimes I have to
> click on Subscribe to get that popup. I re-enter my Google account info,
> re-enter new Google Authenticator id.
> Then it finds all my Gmail folders, and proceeds to re-download all my
> online messages in all my gmail folders.
> When my Gmail folders are re-read, my Thunderbird filters process the
> messages...again...resulting in multiple copies of the same messages in the
> appropriate folders.
> 
> 
> Expected results:
> 
> Thunderbird should remember my credentials, as it has done for many years. I
> should not have to re-enter this stuff several times/day. I should not have
> to re-subscribe to all my folders. I should not have to go through all my
> hundreds of mail folders and manually run "Remove Duplicates".

not to deminish the issue, but there are addons that will remove duplicates such as https://addons.mozilla.org/en-US/thunderbird/addon/remove-duplicate-messages-alte/
Flags: needinfo?(steve)
See Also: → bug 855836, bug 1240722
Summary: imap account info lost after crash and restart → imap account / subscription info lost after crash and restart (gmail)
(In reply to Steve Kelem from comment #0)
> Steps to reproduce:
> Bug summary : imap account / subscription info lost after crash and restart (gmail)

What do mean by "subscription info lost"?
"subscribed state of mbox" is always held in imap server, and Thunderbird doesn't hold it in locally and doesn't use such "locally held data" after restart. "subscribed state of mbox" is always obtained from imap server in Thunderbird.

> After thunderbird crashes (which is many times/day), I restart thunderbird.
> Right click on Gmail account, select Subscribe, and the Subscription window folder list is empty.

Following is already known issue.
  When no connection with server is established yet, "subscribe" fails to login/issue subscribe so result is blank.
Do you see this issue?
IIRC, this issue seems resolved in Tb 45.
  When no connection with server is established yet, "subscribe" logins and issues subscribe, the result is shown.

> Expected results:
> Thunderbird should remember my credentials, as it has done for many years.
> I should not have to re-enter this stuff several times/day.

What do you mean by "my credentials"? What kind of data which is relevant to issue about "subscribed state data of imap mbox" of this bug report?

> I should not have to re-subscribe to all my folders.

Even when following already known problem happened,
  When no connection with server is established yet, "subscribe" fails to login/issue subscribe so result is blank.
AFAIK, after server connection was establised at a cached connection by new mail check, folder open by folder click at folder pane etc. LSUB command was normally issued and subsribed state was obtained from imap server and subscribed state was shown.

What operation do you call "have to re-subscribe to all my folders"?

> I should not have to go through all my hundreds of mail folders and manually run "Remove Duplicates".

Duplicate imap folders? Remove duplicate imap folders? What was run by the manual run of "Remove Duplicates"?
(This is report about subscribe at B.M.O, so relevant issue is issue arround mbox itself in normal/ordinal world)

Updated

3 months ago
Whiteboard: [dupme][notacrash]

Updated

27 days ago
Blocks: 402793
(Reporter)

Comment 3

5 days ago
Not reproducible.
The problem isn't occurring any more. I don't know what fixed it.
Thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 days ago
Flags: needinfo?(steve)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.