Closed Bug 1322413 Opened 3 years ago Closed 3 years ago

Background highlight of selected text not visible on light backgrounds

Categories

(Core :: Widget: Gtk, defect)

x86_64
Linux
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1322120
Tracking Status
firefox53 --- affected

People

(Reporter: bws42, Unassigned)

References

Details

Attachments

(2 files)

This is a fairly recent regression. When highlighting text on a white background a very light gray color is used instead of the blue that was previously used. That highlight is not very noticeable. The same highlight is used in dropdowns.

The same issue appears to impact the focus ring on the address bar, but not the focus ring on this text area (which remains blue).
For me the nightly from November 30th works, and December 1st does not:

https://hg.mozilla.org/mozilla-central/rev/13736e2db6eb94b02dd28cc88f2943b8109aa374 works
https://hg.mozilla.org/mozilla-central/rev/cd4cdcc9ad6c45dad8b8d8c0d40e459db2bca8a1 busted

I'd be happy to try and look at hourlies if someone reminds me where they are.
Regression of bug 1320860? Does it reproduce on https://archive.mozilla.org/pub/firefox/tinderbox-builds/autoland-linux64/1480528364/ and not on https://archive.mozilla.org/pub/firefox/tinderbox-builds/autoland-linux64/1480474861/ ?
Component: Theme → Widget: Gtk
Flags: needinfo?(mozilla)
Product: Firefox → Core
Yes, those builds behave exactly as you've specified.

I'm running Debian 8 (Jessie). Let me know if you need any library information.
Flags: needinfo?(mozilla)
Blocks: 1320860
Thanks for the report and regression range.
I'll post what I think is a fix for this to bug 1322120.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1322120
You need to log in before you can comment on or make changes to this bug.