building firefox/ARM64 fails, include/nspr/prtypes.h:585:38: error: size of array ‘arg’ is negative

RESOLVED FIXED in 3.29

Status

NSS
Build
RESOLVED FIXED
11 months ago
10 months ago

People

(Reporter: sk, Assigned: sk)

Tracking

({64bit, arch})

trunk
3.29
Other
Linux
64bit, arch

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Assignee)

Description

11 months ago
Created attachment 8817335 [details]
build.log

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/55.0.2883.75 Safari/537.36

Steps to reproduce:

building firefox on arm64


Actual results:

building fails


Expected results:

building success
(Assignee)

Updated

11 months ago
Keywords: 64bit, arch
OS: Unspecified → Linux
Hardware: Unspecified → Other
(Assignee)

Comment 1

10 months ago
Created attachment 8818130 [details] [diff] [review]
Fix-freebl-gyp-on-arm64.patch
Attachment #8818130 - Flags: review?(gps)
(Assignee)

Updated

10 months ago
Component: Libraries → Build
Comment on attachment 8818130 [details] [diff] [review]
Fix-freebl-gyp-on-arm64.patch

Review of attachment 8818130 [details] [diff] [review]:
-----------------------------------------------------------------

Redirect to Ted since he wrote the NSS GYP code recently. I suspect he'll tell you to submit this against the NSS project.
Attachment #8818130 - Flags: review?(gps) → review?(ted)
Comment on attachment 8818130 [details] [diff] [review]
Fix-freebl-gyp-on-arm64.patch

Review of attachment 8818130 [details] [diff] [review]:
-----------------------------------------------------------------

This needs to land in the NSS repo.
Attachment #8818130 - Flags: review?(ted) → review+
Assignee: nobody → sk.alvin.x
(Assignee)

Updated

10 months ago
Keywords: checkin-needed

Comment 4

10 months ago
Pushed by ihsiao@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/17f6d9f37a21
building firefox/ARM64 fails, include/nspr/prtypes.h:585:38: error: size of array ‘arg’ is negative. r=ted.
Keywords: checkin-needed

Comment 5

10 months ago
Hi franziskus,
Please help to land this to NSS, thank you.
Flags: needinfo?(franziskuskiefer)

Comment 6

10 months ago
Backout by ihsiao@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/66b31b9d9a1a
Backed out changeset 17f6d9f37a21 for this should be land to NSS
https://hg.mozilla.org/projects/nss/rev/ad4588ca0c63d9160c521e53e7e691ee292526b6
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 months ago
Flags: needinfo?(franziskuskiefer)
Resolution: --- → FIXED
Target Milestone: --- → 3.29
We also have to check for aarch64
https://hg.mozilla.org/projects/nss/rev/398475e2f9703edd809572ec3e6594b34cdff99a
You need to log in before you can comment on or make changes to this bug.