Clicked button doesn't become the activeElement

RESOLVED INVALID

Status

()

Core
Event Handling
RESOLVED INVALID
a year ago
a year ago

People

(Reporter: joel.lear, Unassigned)

Tracking

({testcase})

52 Branch
Unspecified
Mac OS X
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/54.0.2840.99 Safari/537.36

Steps to reproduce:

1. Use this fiddle: https://jsfiddle.net/aytj5489/
2. Click the button on Mac with Firefox


Actual results:

The active element is the Body.


Expected results:

The button should be the active element since it was just clicked. This only happens on Mac, FF on windows this displays "button".
(Reporter)

Updated

a year ago
OS: Unspecified → Mac OS X

Updated

a year ago
Component: Untriaged → Untriaged
Keywords: testcase
Product: Firefox → Core
User Agent  Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:53.0) Gecko/20100101 Firefox/53.0

I have tested this issue on Mac OS 10.12 with the latest Firefox release (50.0.2) and the latest Nightly (53.0a1-20161211030209) and managed to reproduce it.
When navigating to the URL provided in the description and clicking on the "Click" button, the active element is the Body.
Status: UNCONFIRMED → NEW
Component: Untriaged → Event Handling
Ever confirmed: true
button doesn't get focused on OSX. IIRC Safari has the same behavior.
Neil would remember this better.
Flags: needinfo?(enndeakin)

Comment 3

a year ago
That's correct.
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(enndeakin)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.