Make some mScanInProgress checks MOZ_RELEASE_ASSERT

RESOLVED FIXED in Firefox 51

Status

()

defect
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: mccr8, Assigned: mccr8)

Tracking

unspecified
mozilla53
Points:
---

Firefox Tracking Flags

(firefox51 fixed, firefox52 fixed, firefox53 fixed)

Details

Attachments

(1 attachment)

The cycle collector uses mScanInProgress to guard against reentrance. We assert that it isn't true in a number of places. A few of those places are at the start of CC phases. We might as well make those asserts fatal, because we don't call them much, so it would be cheap to do.
Comment on attachment 8817519 [details]
Bug 1322536 - Make some mScanInProgress checks fatal in release builds.

https://reviewboard.mozilla.org/r/97730/#review98118
Attachment #8817519 - Flags: review?(bugs) → review+
Pushed by amccreight@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3be54c62e001
Make some mScanInProgress checks fatal in release builds. r=smaug
https://hg.mozilla.org/mozilla-central/rev/3be54c62e001
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
Comment on attachment 8817519 [details]
Bug 1322536 - Make some mScanInProgress checks fatal in release builds.

Approval Request Comment
[Feature/Bug causing the regression]: unknown
[User impact if declined]: I am investigating a crash.
[Is this code covered by automated tests?]: yes
[Has the fix been verified in Nightly?]: The crash has been on Nightly for a few days without any obvious stability problems.
[Needs manual test from QE? If yes, steps to reproduce]: no
[List of other uplifts needed for the feature/fix]: none
[Is the change risky?]: No.
[Why is the change risky/not risky?]: This patch makes us crash in release builds in certain conditions. If we hit that condition, even without this patch, very bad things are likely to happen, so this should only improve things, because at least we're crashing cleanly.
[String changes made/needed]: none
Attachment #8817519 - Flags: approval-mozilla-beta?
Attachment #8817519 - Flags: approval-mozilla-aurora?
Comment on attachment 8817519 [details]
Bug 1322536 - Make some mScanInProgress checks fatal in release builds.

This patch can help investigate a crash. Beta51+ and Aurora52+. Should be in 51 beta 8.
Attachment #8817519 - Flags: approval-mozilla-beta?
Attachment #8817519 - Flags: approval-mozilla-beta+
Attachment #8817519 - Flags: approval-mozilla-aurora?
Attachment #8817519 - Flags: approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.