Contents in a div with overflow:auto/scroll does not wrap

RESOLVED DUPLICATE of bug 131802

Status

()

Core
CSS Parsing and Computation
RESOLVED DUPLICATE of bug 131802
16 years ago
4 years ago

People

(Reporter: Per Johansson, Assigned: dbaron)

Tracking

({css2})

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.9) Gecko/20020311
BuildID:    2002031104

The page has two divs, an upper and a lower with fixed positioning. The lower
div contains some text which won't wrap but extends beyond the window border to
the right. If a force a redraw by dragging the border of the Mozilla window, the
text gets wrapped correctly. Just a reload does not help.

Reproducible: Always
Steps to Reproduce:
1.Type the URL in the combobox and press "Enter"
2.
3.

Actual Results:  Page opened with text unwrapped.

Expected Results:  Wrapped the text.

This is true with Mozilla on OS/2 4.5 and Windows NT 4, but it used to work in
earlier builds (0.9.5 I think).
(Reporter)

Updated

16 years ago
Keywords: css2
Marc, jkeiser here's another one.  It works correctly when overflow is visible
or hidden (text wraps), fails when overflow is scroll or auto.  And it fails
whether position is fixed or static (so changing summary).

Most likely a duplicate of bug 132156
Status: UNCONFIRMED → NEW
Depends on: 132156
Ever confirmed: true
Summary: Contents in a div with fixed positioning does not wrap → Contents in a div with overflow:auto/scroll does not wrap
Saw this same bug (with divs) floating around a few days ago, IIRC.  I'll look.
Whiteboard: DUPEME

Comment 3

16 years ago

*** This bug has been marked as a duplicate of 131802 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.